Bug 1014466 - Kwin crashes intermittently when opening LibreOffice
Kwin crashes intermittently when opening LibreOffice
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kde-workspace (Show other bugs)
19
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 02:49 EDT by Peter Gückel
Modified: 2014-03-03 23:09 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-03 23:09:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
debuginfo (3.69 KB, text/plain)
2013-10-02 21:20 EDT, Peter Gückel
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 325569 None None None Never

  None (edit)
Description Peter Gückel 2013-10-02 02:49:01 EDT
Description of problem:
Roughly every second or third time I open LibreOffice calc (not so sure about writer), plasma crashes. This has been going on for quite a while, perhaps more than a month. I cannot say exactly when it started, somewhere around kde-4.10 or kde-4.11, likely the former.

Version-Release number of selected component (if applicable):
kde-workspace-4.11.2-1.fc19.x86_64
libreoffice-core-4.1.2.2-1.fc19.x86_64

How reproducible:
Open libreoffice-calc. Try it a few times, since it isn't every time, but very often, every 2-3 times or so.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Old behaviour: no plasma crashes.

Additional info:
Comment 1 Rex Dieter 2013-10-02 07:40:44 EDT
Can you provide any backtraces (from abrt or drkonqi or whatever)?
Comment 2 Peter Gückel 2013-10-02 13:11:46 EDT
(In reply to Rex Dieter from comment #1)
> Can you provide any backtraces (from abrt or drkonqi or whatever)?

OK, next time it happens, I will save it. Do I need to install the debug packages? If so, which ones?
Comment 3 Rex Dieter 2013-10-02 13:35:42 EDT
debuginfo is indeed required for a good backtrace, drkonqi/abrt should handle that part for you.
Comment 4 Peter Gückel 2013-10-02 21:07:34 EDT
I was unable to cause a kwin
Comment 5 Peter Gückel 2013-10-02 21:20:26 EDT
Created attachment 806824 [details]
debuginfo

The program stated that this report provides useful information (***).
Comment 6 Peter Gückel 2013-10-02 21:33:19 EDT
Ignore comment 4.
By the way, it is kwin that crashes.

Anyway, I had a hard time causing for a crash, and then, when I wasn't expecting it, it happened.

I used drkonqi (says Crash Reporting Assistant in titlebar). It downloaded 79 debuginfo packages and wanted some others from kde-redhat, that it couldn't find. I installed them manually while the other packages were downloading.

Unfortunately, not all of them were in kde-redhat/testing, but I guessed and I must have gotten the correct ones;

Just for your information, it wanted:

kdelibs-debuginfo

kde-workspace-debuginfo
kde-workspace-libs-debuginfo (not found)
libworkspace-debuginfo (not found)

kdepimlibs-debuginfo
kdepimlibs-akonadi-debuginfo (not found)

kactivities-debuginfo

ksysguard-libs-debuginfo (not found)

nepomuk-core-libs-debuginfo (not found, but I installed nepomuk-core-debuginfo)

So...

I allowed drkonqi to run and, once it finished, it asked me to log in to bugzilla. I am guessing that it wanted to generate a new bug report, which seems pointless (I think), so I just saved the output. It appears as an attachment to this bug report.

I just wanted to note some of the surrounding conditions:

I had firefox opened at the same time (on a different virtual desktop) as I attempted to open libreoffice-calc by clicking on a file name in dolphin. Firefox was displaying only a blank page with the tiles.

I am using desktop effects. I am using OpenGL 2.0 compositing, Qt native graphics.

Enabled effects are:

Zoom
Dashboard
Fade
Highlight Window
Kscreen
Login
Logout
Maximize
Minimize Animation
Screen Edge
Screenshot
Slide
Sliding Popups
Translucency
wobbly Windows
Startup Feedback
Dialog Parent
Dim Screen for Administrator Mode
Desktop Grid
Present Windows

There is nothing else I can think of.
Comment 7 Rex Dieter 2013-10-03 01:12:38 EDT
may not be relevant, but I'd recommend using raster over native rendering (it is the upstream/recommmended default)
Comment 8 Rex Dieter 2013-10-03 01:15:45 EDT
Anyway, my recommendation would be, when/if this crashes again, to allow drkonqi to file an upstream bug at this point
Comment 9 Peter Gückel 2013-10-03 01:27:52 EDT
OK, I switched it to raster.

I never changed it (maybe it got changed automatically when I experimented with OpenGL3 ?), so I am surprised it is the default.
Comment 10 Peter Gückel 2013-10-03 01:29:05 EDT
I think I'll just do it manually, since it crashes numerous times a day anyway. I will just copy the debug output and link to this report. Non?
Comment 11 Peter Gückel 2013-10-03 01:38:11 EDT
https://bugs.kde.org/show_bug.cgi?id=325569
Comment 12 Peter Gückel 2014-03-03 23:09:36 EST
This is so old that I forgot about it. It clearly was the change to raster that solved it.

I think there is no reason not to close this, as it was clearly the non-standard setting I had used that caused the problem.

Note You need to log in before you can comment on or make changes to this bug.