Bug 101449 - rpm crashes when --prefix option is specified
Summary: rpm crashes when --prefix option is specified
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm   
(Show other bugs)
Version: 3.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-01 07:31 UTC by Winfrid Tschiedel
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-20 19:46:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to fix rpm (436 bytes, patch)
2003-08-04 21:30 UTC, hjl
no flags Details | Diff

Description Winfrid Tschiedel 2003-08-01 07:31:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
Installation of Intel Compilers Version 8.0 fail on RHEL 3.0 Beta 1.
There is no problem on RHEL 2.1

10. TERMINATION OF THIS LICENSE: The term of this Agreement will commence on the
Where do you want to install to?  Specify directory starting with '/'.  [/opt/in
tel_cc_80]
/opt/intel/compiler80
What rpm install options would you like?  [-U --replacefiles]


--------------------------------------------------------------------------------
Substitute Headers for Intel(R) C++ Itanium(R) Compiler for Itanium(R)-based app
lications Version 8.0 Beta Build 20030508 Package ID: l_cc_b_8.0.023
Installing...
./install.sh: line 620:  4351 Segmentation fault      rpm $OPTIONS $PREFIX $CHOS
ENRPM >&$TEMPFILE.rpmout
Installation failed.

There is no problem if the default prefix is used.



Version-Release number of selected component (if applicable):
rpm-4.2.1-0.29

How reproducible:
Always

Steps to Reproduce:
1. Get Intel Compilers Version 8 and install the product according
   the instructions and select during installation a directory which 
   not default.
2. The problem should be reproducible with any relocable product
   e.g. rpm -ivh --prefix /tmp/xxx xxx.rpm
3.
    

Actual Results:  rpm fails with segmentation fault

Expected Results:  rpm installs product to specified directories

Additional info:

Comment 1 Jeff Johnson 2003-08-01 16:21:07 UTC
Try with latest rpm-4.2.1-0.31 rpm, I believe problem is already
fixed there.

Reopen this bug if reproducible with rpm-4.2.1-0.31.

Comment 2 Winfrid Tschiedel 2003-08-04 08:08:00 UTC
Please tell me, where I can find rpm-4.2.1-0.31
I found only rpm-4.2.1-0.30
but with this level rpm still crashes

Winfrid

Comment 3 hjl 2003-08-04 21:30:42 UTC
Created attachment 93387 [details]
A patch to fix rpm

FWIW, this patch works for me.

# rpm -qp --qf "%{FILECOLORS}\n" intel-icc8-8.0-17.i386.rpm
(none)

Comment 4 Jeff Johnson 2003-08-20 19:46:06 UTC
You will have to wait for rpm-4.2.1-0.31 to be made available.

Yes, (from memory) the fix was little more than avoiding a null pointer.

Comment 5 Orion Poplawski 2004-06-30 17:13:56 UTC
Will rpm-4.2.1-0.31 ever be made available for Fedora Core 1?


Note You need to log in before you can comment on or make changes to this bug.