Bug 101457 - Mozilla segfaults with new glibc
Summary: Mozilla segfaults with new glibc
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: mozilla   
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Keywords:
: 101460 101516 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-01 14:18 UTC by Sammy
Modified: 2007-04-18 16:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-14 20:00:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2003-08-01 14:18:49 UTC
After installing glibc-2.3.2-66 mozilla segfaults everytime. Going back to -57 
solves the problem. Perhaps need to recompile mozilla?

Comment 1 Kaj J. Niemi 2003-08-01 15:06:26 UTC
*** Bug 101460 has been marked as a duplicate of this bug. ***

Comment 2 Jakub Jelinek 2003-08-01 20:53:21 UTC
Chris, is there any way how to turn off SIGSEGV signal handlers in mozilla
(best via env variable)?

Comment 3 Ralph Loader 2003-08-02 05:49:33 UTC
*** Bug 101516 has been marked as a duplicate of this bug. ***

Comment 4 Jakub Jelinek 2003-08-02 18:09:10 UTC
I've managed to get is segfault normally if I rm -rf ~/.mozilla first.
Don't know if it is the same segfault as seen otherwise though.
It dies in malloc, so I've tried ElectricFence.
deallocate_tsd there calls _pt_thread_death with a pointer which have been
previously freed.

Anyway, while I keep looking at this, could others who are experiencing this
problem try to downgrade to glibc-2.3.2-63 from RHEL3 beta (taroon)
and see if the problem is already there or happened between -63 and -66?

Comment 5 Kaj J. Niemi 2003-08-02 19:17:17 UTC
Mozilla/epiphany/MozillaFirebird works under glibc-2.3.2-63 from taroon.

Comment 6 Todd Mokros 2003-08-02 21:03:07 UTC
Running linux kernel 2.6.0-test2(bk snapshot) and glibc-2.3.2-66 i686, I get the
mozilla segfault also. (mozilla-1.4-12) rpm-4.2.1-0.30 also has issues.  The
LD_ASSUME_KERNEL=2.2.5 hack appears to workaround the issue, though.

Comment 7 Zach Gelnett 2003-08-02 22:13:42 UTC
I'm getting the segfault also with the new glibc, planning to downgrade

Comment 8 Zach Gelnett 2003-08-03 21:18:58 UTC
my sound server started getting errors also with glibc v.66, i've downgraded 
to 57 and the sound and mozilla both work.

Comment 9 Jakub Jelinek 2003-08-04 06:49:12 UTC
Please try ftp://people.redhat.com/jakub/glibc/2.3.2-68/

Comment 10 Kaj J. Niemi 2003-08-04 09:51:58 UTC
Mozilla, epiphany, etc. work again with -68. Thanks Jakub.

Comment 11 Zach Gelnett 2003-08-06 00:19:34 UTC
sound server still fails to start with -68

going back to 57 where it all works.

Comment 12 Sammy 2003-08-06 13:45:17 UTC
What soundserver? I am using arts and it is working fine! 

Comment 13 Barry K. Nathan 2003-10-22 01:35:46 UTC
Zach, are you still seeing glibc problems with the latest glibc (I think 2.3.2-98)?

Comment 14 Barry K. Nathan 2004-07-14 14:44:02 UTC
I think this bug should be CLOSED/CURRENTRELEASE; this particular
problem with Mozilla & glibc has been dead for a long while now.


Note You need to log in before you can comment on or make changes to this bug.