Bug 1014572 - [Admin Portal] weird 'Loading...' under failed task
[Admin Portal] weird 'Loading...' under failed task
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity low
: ---
: 3.6.0
Assigned To: nobody nobody
Pavel Stehlik
ux
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 07:05 EDT by Jiri Belka
Modified: 2014-07-28 08:08 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-28 08:08:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (17.89 KB, image/png)
2013-10-02 07:05 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2013-10-02 07:05:16 EDT
Created attachment 806389 [details]
screenshot

Description of problem:
I have 'X Importing VM jb-w2k8r2 to Cluster Default' task and under it there's weird 'Loading...'. Loading of what...? :)

See screenshot.

Version-Release number of selected component (if applicable):
is17

How reproducible:
100%

Steps to Reproduce:
1.have a failed task
2.
3.

Actual results:
100%

Expected results:


Additional info:
Comment 1 Einav Cohen 2014-01-16 09:55:11 EST
Gilad - any idea what this 'Loading...' is?
Comment 2 Gilad Chaplik 2014-01-19 04:37:59 EST
(In reply to Einav Cohen from comment #1)
> Gilad - any idea what this 'Loading...' is?

iirc, the tasks are fetched as a list without any inner details (thin). so when expanding a single task, we fetch for a full task data, and put loading indicator in the meanwhile.
Comment 3 Einav Cohen 2014-04-08 08:34:00 EDT
Jiri - does it reproduce in 3.4?
Comment 4 Jiri Belka 2014-04-11 04:16:26 EDT
Can you just give a tip how to make a task failing? The BZ was filled long time ago and I lost all details since that. Thx.
Comment 5 Einav Cohen 2014-06-27 16:43:34 EDT
(In reply to Jiri Belka from comment #4)
> Can you just give a tip how to make a task failing? The BZ was filled long
> time ago and I lost all details since that. Thx.

well, according to the screen-shot, you need to import a VM to the system (from an Export domain, I assume). 
note that the 'Loading...' indication should be displayed, but only during the Tasks-loading into the Tasks bottom-panel. Once the Tasks have been retrieved and displayed, the 'Loading...' indication should disappear. 
Can you please try to reproduce in one of the latest oVirt/RHEV builds?
thanks.
Comment 6 Einav Cohen 2014-07-15 08:56:48 EDT
Jiri - please see my comment #5. thanks.
Comment 7 Jiri Belka 2014-07-28 08:03:24 EDT
I cannot reproduce on oVirt 3.5, so do not take '100%' in 'How reproducible' seriously. As there's no clear reproducer maybe this BZ should be closed.
Comment 8 Einav Cohen 2014-07-28 08:08:11 EDT
(In reply to Jiri Belka from comment #7)
> I cannot reproduce on oVirt 3.5, so do not take '100%' in 'How reproducible'
> seriously. As there's no clear reproducer maybe this BZ should be closed.

Thanks, Jiri.

Note You need to log in before you can comment on or make changes to this bug.