Bug 1014617 - SELinux is preventing /usr/lib64/nspluginwrapper/plugin-config from 'execute' accesses on the file /tmp/mathworks_9808/bin/glnxa64/libstdc++.so.6.
SELinux is preventing /usr/lib64/nspluginwrapper/plugin-config from 'execute'...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:bb0a3764fdd846f3b19cb92c793...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 08:07 EDT by r.v.f
Modified: 2013-10-04 11:42 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 11:25:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description r.v.f 2013-10-02 08:07:13 EDT
Description of problem:
Install MATLAB R2013a. At the end of the installation process, the program asks to install the MATLAB Compiler Runtime and provides a link to it. Clicking on this link leads to the SELinux alert. 
SELinux is preventing /usr/lib64/nspluginwrapper/plugin-config from 'execute' accesses on the file /tmp/mathworks_9808/bin/glnxa64/libstdc++.so.6.

*****  Plugin catchall (100. confidence) suggests  ***************************

If sie denken, dass es plugin-config standardmässig erlaubt sein sollte, execute Zugriff auf libstdc++.so.6 file zu erhalten.
Then sie sollten dies als Fehler melden.
Um diesen Zugriff zu erlauben, können Sie ein lokales Richtlinien-Modul erstellen.
Do
zugriff jetzt erlauben, indem Sie die nachfolgenden Befehle ausführen:
# grep plugin-config /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_config_t:
                              s0-s0:c0.c1023
Target Context                unconfined_u:object_r:user_tmp_t:s0
Target Objects                /tmp/mathworks_9808/bin/glnxa64/libstdc++.so.6 [
                              file ]
Source                        plugin-config
Source Path                   /usr/lib64/nspluginwrapper/plugin-config
Port                          <Unbekannt>
Host                          (removed)
Source RPM Packages           nspluginwrapper-1.4.4-17.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-74.8.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.1-200.fc19.x86_64 #1 SMP Sat
                              Sep 14 15:04:51 UTC 2013 x86_64 x86_64
Alert Count                   28
First Seen                    2013-10-02 13:56:47 CEST
Last Seen                     2013-10-02 13:59:06 CEST
Local ID                      3a506c21-8cad-41a7-9655-512597f8e12a

Raw Audit Messages
type=AVC msg=audit(1380715146.268:1866): avc:  denied  { execute } for  pid=11125 comm="plugin-config" path="/tmp/mathworks_9808/bin/glnxa64/libstdc++.so.6" dev="tmpfs" ino=549940 scontext=unconfined_u:unconfined_r:mozilla_plugin_config_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_tmp_t:s0 tclass=file


type=SYSCALL msg=audit(1380715146.268:1866): arch=x86_64 syscall=mmap success=no exit=EACCES a0=0 a1=30e018 a2=5 a3=802 items=0 ppid=11103 pid=11125 auid=1000 uid=99 gid=99 euid=99 suid=99 fsuid=99 egid=99 sgid=99 fsgid=99 ses=1 tty=pts1 comm=plugin-config exe=/usr/lib64/nspluginwrapper/plugin-config subj=unconfined_u:unconfined_r:mozilla_plugin_config_t:s0-s0:c0.c1023 key=(null)

Hash: plugin-config,mozilla_plugin_config_t,user_tmp_t,file,execute

Additional info:
reporter:       libreport-2.1.7
hashmarkername: setroubleshoot
kernel:         3.11.1-200.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-10-04 11:25:32 EDT
I suggest you turn off the confinement.

setsebool -P  unconfined_mozilla_plugin_transition 1


I really do not want to allow plugins to download and execute content on a system
Comment 2 r.v.f 2013-10-04 11:42:05 EDT
Problem seems to be fixed in R2013b anyway

Note You need to log in before you can comment on or make changes to this bug.