Bug 1014621 - RhnSyncException('\nError Message:\n No such erratum rhn-erratum-24607\nError
RhnSyncException('\nError Message:\n No such erratum rhn-erratum-24607\nError
Status: CLOSED DUPLICATE of bug 1014396
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michael Mráka
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 08:20 EDT by dcwilliams
Modified: 2013-10-11 07:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-11 07:03:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dcwilliams 2013-10-02 08:20:45 EDT
Description of problem:sync failed


Version-Release number of selected component (if applicable):


How reproducible:
Reproduces on every sync either automated or manual.

Steps to Reproduce:
1.execute satellite-synch
2.
3.

Actual results:
Sync fails

Expected results:
Syncc suceed.

Additional info:
07:34:07 
SYNC ERROR:

Exception reported from ghs-rhs01
Time: Wed Oct  2 07:34:07 2013
Exception type <class 'spacewalk.satellite_tools.syncLib.RhnSyncException'>

Exception Handler Information
Traceback (most recent call last):
  File "/usr/bin/satellite-sync", line 139, in main
    return satsync.Runner().main()
  File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/satsync.py", line 225, in main
    ret = method()
  File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/satsync.py", line 333, in _step_download_errata
    return self.syncer.download_errata()
  File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/satsync.py", line 1529, in download_errata
    stream_loader.process)
  File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/satsync.py", line 1572, in _proces_batch
    prompt, nevermorethan, process_function_args)
  File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/satsync.py", line 1552, in _processWithProgressBar
    process_function(chunk, *process_function_args)
  File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/satsync.py", line 1995, in process
    stream = self.loader(*args)
  File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/xmlWireSource.py", line 253, in getErrataXmlStream
    return self._openSocketStream("dump.errata", (self.systemid, erratumIds))
  File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/xmlWireSource.py", line 155, in _openSocketStream
    stream = apply(func, params)
  File "/usr/lib/python2.6/site-packages/rhn/rpclib.py", line 649, in __call__
    return self._send(self._name, args)
  File "/usr/lib/python2.6/site-packages/rhn/rpclib.py", line 383, in _request
    self._handler, request, verbose=self._verbose)
  File "/usr/lib/python2.6/site-packages/rhn/transports.py", line 188, in request
    return self._process_response(fd, connection)
  File "/usr/lib/python2.6/site-packages/spacewalk/satellite_tools/connection.py", line 47, in _process_response
    ret = self.parse_response(fd)
  File "/usr/lib/python2.6/site-packages/rhn/transports.py", line 240, in parse_response
    return u.close()
  File "/usr/lib64/python2.6/xmlrpclib.py", line 838, in close
    raise Fault(**self._stack[0])
RhnSyncException: 
Error Message:
    No such erratum rhn-erratum-24607
Error Class Code: 3005
Error Class Info: Unable to retrieve erratum
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.



Taskomatic bunch cobbler-sync-bunch was scheduled to run within the cobbler-sync-default schedule.

Subtask cobbler-sync failed.

For more information check /var/lib/rhn/tasko/sat/cobbler-sync-bunch/cobbler-sync_1676425_err.
Comment 1 RHEL Product and Program Management 2013-10-02 08:45:38 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Mike McCune 2013-10-10 12:04:58 EDT
This is a Satellite 5 bug, moving to the proper product.
Comment 4 Clifford Perry 2013-10-11 07:03:49 EDT

*** This bug has been marked as a duplicate of bug 1014396 ***

Note You need to log in before you can comment on or make changes to this bug.