Bug 1014689 - Resource metric graph portlet shows graph incorrectly when there is not enough space
Resource metric graph portlet shows graph incorrectly when there is not enoug...
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity unspecified
: ER05
: JON 3.2.0
Assigned To: Mike Thompson
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 10:32 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 15:43:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example (489.52 KB, image/png)
2013-10-02 10:32 EDT, Libor Zoubek
no flags Details

  None (edit)
Description Libor Zoubek 2013-10-02 10:32:41 EDT
Created attachment 806521 [details]
example

Description of problem:


Version-Release number of selected component (if applicable):
JON 3.2.ER2

How reproducible: always


Steps to Reproduce:
1. have a metric with big maximum 3 or more hours ago
2. place graph of this metric to dashboard and make place for that portlet thin

Actual results: 

Metric graph displays only 1 or 2 hour history, but values are rendered as it was full 8hours interval. 3 hours old big maximum defines maximum for Y axis, but this is wrong. Maximum must be derived from value currently displayed. This may lead to situation when you cannot even hover actual values, because maximum was very high in the past, see screenshot (bottom left).


Expected results: both graps on screenshot (bottom left & bottom right) should look +- similar


Additional info:
Comment 1 Mike Thompson 2013-10-08 22:17:13 EDT
This is as designed. They both use the same interval widths (for instance, 8 m), except that the thin (cut down) graph can only display a smaller number of bars. This way, they look consistent when comparing graphs between large and small as they use the same units. If you need more history move the graph over to the larger column.

Note You need to log in before you can comment on or make changes to this bug.