This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1014712 - Installer displays DB/JDBC password in plain text in UI
Installer displays DB/JDBC password in plain text in UI
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 11:15 EDT by Len DiMaggio
Modified: 2014-02-06 10:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (79.69 KB, image/png)
2013-10-02 11:18 EDT, Len DiMaggio
no flags Details

  None (edit)
Description Len DiMaggio 2013-10-02 11:15:54 EDT
Description of problem:

See attached screenshot - the UI should not display any passwords in clear text.

Version-Release number of selected component (if applicable):
ER4

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-10-02 11:18:43 EDT
Created attachment 806532 [details]
Screenshot
Comment 3 Thomas Hauser 2013-10-02 11:58:32 EDT
IzPack inflexibility coming to bite us again. Will be in next build.
Comment 4 Francisco Canas 2013-10-02 12:02:51 EDT
This issue will be fixed with the next build of Izpack for FSW ER4.

http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=dfcaee100fd4224d8746b4da5d58f8b09d420145
Comment 7 Thomas Hauser 2013-10-07 09:53:22 EDT
This fix won't actually appear in the beta (since we did not use the newest IzPack.)
Comment 10 Len DiMaggio 2014-01-06 13:53:18 EST
Verified in ER8

Note You need to log in before you can comment on or make changes to this bug.