Bug 1014719 - creation of ppc64 boot images fails
creation of ppc64 boot images fails
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: David Shea
Marian Ganisin
:
Depends On:
Blocks: 1018217
  Show dependency treegraph
 
Reported: 2013-10-02 11:23 EDT by Lubos Kocman
Modified: 2013-11-21 04:41 EST (History)
7 users (show)

See Also:
Fixed In Version: anaconda-13.21.209-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1018217 (view as bug list)
Environment:
Last Closed: 2013-11-21 04:41:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lubos Kocman 2013-10-02 11:23:15 EDT
Description of problem:

image creation of ppc64 netboot images fails in recent nightly.

Logs are available:

/mnt/redhat/brewroot/work/tasks/8848/6358848/runroot.log (109MB)
or http://download.devel.redhat.com/brewroot/work/tasks/8848/6358848/

Compose logs:
http://download.lab.bos.redhat.com/nightly/RHEL6.5-20131002.n.1/work/ppc64/buildinstall/logs/

Additional info:

This is a Snapshot 2 breaker. Last successful compose was on thursday then compose failed due fips and python-multilib issues. Yesterday's respin of nightly was first which fail on this issue.

Just to limit the bounds.
Comment 1 RHEL Product and Program Management 2013-10-02 11:54:20 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 3 David Cantrell 2013-10-02 15:42:52 EDT
The test compose failed, but due to an actual problem rather than a faulty mk-images script.  The netboot image on ppc64 is 55k over the size limit, so we should track that as a separate problem.

Requesting a qa_ack+ now so we can push this change.
Comment 4 David Cantrell 2013-10-02 16:10:18 EDT
New test compose is running to see if we can get the ppc64 netboot image down to the right size:

http://download.lab.bos.redhat.com/devel/candidate-trees/RHEL6.5-20131002.1/
Comment 5 David Shea 2013-10-02 17:59:38 EDT
The last netboot is even bigger, but I also found a problem with the script where it would have still rejected the image if it had been under the target size. I've posted a new patch to fix that.
Comment 6 David Cantrell 2013-10-03 08:19:53 EDT
New test build of anaconda running with the updated patch mentioned in comment #5:

http://brewweb.devel.redhat.com/brew/taskinfo?taskID=6365758
Comment 8 Dennis Gregorovic 2013-10-03 19:44:39 EDT
anaconda-13.21.208-1 still fails:

/mnt/redhat/devel/candidate-trees/RHEL6.5-20131003.4/logs/ppc64-logs/buildinstall.log

It does seem to get farther than before, which is why the test compose passed.  However, buildinstall is still throwing an error and there are a number of files missing.

GOOD:
$ find RHEL6.5-20130925.2/work/ppc64/buildinstall -type f
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/ppc64/os/.treeinfo
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/ppc64/os/images/netboot/ppc64.img
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/ppc64/os/images/install.img
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/ppc64/os/images/boot.iso
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/ppc64/os/ppc/ppc64/initrd.img
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/ppc64/os/ppc/ppc64/vmlinuz
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/ppc64/os/ppc/ppc64/yaboot.conf
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/ppc64/os/ppc/chrp/yaboot
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/ppc64/os/ppc/bootinfo.txt
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/ppc64/os/ppc/efika.forth
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/ppc64/os/etc/yaboot.conf
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/ppc64/os/.discinfo
RHEL6.5-20130925.2/work/ppc64/buildinstall/6.5/.composeinfo
RHEL6.5-20130925.2/work/ppc64/buildinstall/logs/ppc64.log

BAD:
$ find RHEL6.5-20131003.4/work/ppc64/buildinstall -type f
RHEL6.5-20131003.4/work/ppc64/buildinstall/6.5/ppc64/os/.treeinfo
RHEL6.5-20131003.4/work/ppc64/buildinstall/6.5/ppc64/os/images/netboot/ppc64.img
RHEL6.5-20131003.4/work/ppc64/buildinstall/6.5/ppc64/os/ppc/ppc64/initrd.img
RHEL6.5-20131003.4/work/ppc64/buildinstall/6.5/ppc64/os/ppc/ppc64/vmlinuz
RHEL6.5-20131003.4/work/ppc64/buildinstall/6.5/ppc64/os/ppc/ppc64/yaboot.conf
RHEL6.5-20131003.4/work/ppc64/buildinstall/logs/ppc64.log
Comment 15 errata-xmlrpc 2013-11-21 04:41:57 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1588.html

Note You need to log in before you can comment on or make changes to this bug.