Bug 1014736 - Bad advice to use TCP for large clusters
Bad advice to use TCP for large clusters
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.2.0
Assigned To: gsheldon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 12:07 EDT by dereed
Modified: 2013-11-07 17:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.7 Build Name: 11621, Administration and Configuration Guide-6-1 Build Date: 21-01-2013 16:29:26
Last Closed: 2013-11-07 17:49:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dereed 2013-10-02 12:07:44 EDT
Document URL: 
https://access.redhat.com/site/documentation/en-US/JBoss_Data_Grid/6/html-single/Administration_and_Configuration_Guide/index.html#sect-Pre-Configured_JGroups_Files

Section Number and Name: 
20.4.2.3. jgroups-tcp.xml

Describe the issue: 
The documentation states that TCP "is better suited to smaller clusters (under 100 nodes) only when using distribution mode. This is because TCP is more efficient as a point-to-point protocol."

This is completely wrong.  TCP is never more efficient as a JGroups transport.
It is slightly worse in small clusters, and WAY worse in large clusters.

TCP is usually only used for JGroups when multicast UDP is not an option, and only for small clusters (I would never consider TCP for 100 nodes as this section also states).

Suggestions for improvement: 
Change this to state TCP is generally used only if multicast UDP is not an option, and should only be used in clusters smaller than X (which I believe should be WAY lower than 100).

The note about distribution should remain.  (the maximum cluster size TCP can be used in for DIST will be larger than for REPL/INVALIDATION).

Additional information:
Comment 3 gsheldon 2013-10-02 21:16:27 EDT
Thanks for filing this bug dereed.

Adding NEEDINFO for mgencur to establish the maximum cluster size for TCP. 

Current Infinispan documentation advises "under 100 nodes". 

Martin, do you have any input as to recommended maximum cluster sizes when using TCP in DIST, as well as REPL and INVALIDATION?
Comment 4 Martin Gencur 2013-10-03 05:32:28 EDT
Hmm, I think we already discussed it some time ago and the conclusion was that UDP performed better for 8-node cluster and bigger. This was also confirmed by our tests.

When we tested 4-node cluster, the results were more or less the same for both TCP and UDP.
Comment 11 Misha H. Ali 2013-10-15 19:51:45 EDT
Changes look acceptable to me. Please add comments if there is a reason to reopen to this bug. Thanks, Gemma!
Comment 12 Misha H. Ali 2013-11-07 17:49:34 EST
This bug is approved and available at:

https://access.redhat.com/site/documentation/Red_Hat_JBoss_Data_Grid/

Note You need to log in before you can comment on or make changes to this bug.