Bug 1014770 - [abrt] abort on creation of NAP connection for bluez device
[abrt] abort on creation of NAP connection for bluez device
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Haller
Fedora Extras Quality Assurance
abrt_hash:13b516c2ac2b15b8c7e68e58d4d...
:
: 1015543 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 14:00 EDT by bober
Modified: 2013-10-30 16:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.9.0-14.git20131003.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 10:52:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (16.68 KB, text/plain)
2013-10-02 14:00 EDT, bober
no flags Details
File: cgroup (152 bytes, text/plain)
2013-10-02 14:00 EDT, bober
no flags Details
File: core_backtrace (22.07 KB, text/plain)
2013-10-02 14:00 EDT, bober
no flags Details
File: dso_list (4.16 KB, text/plain)
2013-10-02 14:01 EDT, bober
no flags Details
File: environ (72 bytes, text/plain)
2013-10-02 14:01 EDT, bober
no flags Details
File: limits (1.29 KB, text/plain)
2013-10-02 14:01 EDT, bober
no flags Details
File: maps (20.75 KB, text/plain)
2013-10-02 14:01 EDT, bober
no flags Details
File: open_fds (2.50 KB, text/plain)
2013-10-02 14:01 EDT, bober
no flags Details
File: proc_pid_status (903 bytes, text/plain)
2013-10-02 14:01 EDT, bober
no flags Details
File: var_log_messages (10.30 KB, text/plain)
2013-10-02 14:01 EDT, bober
no flags Details
[PATCH] koji commit for NetworkManager-0.9.9.0-13test.git20131001.fc20.src.rpm (6.23 KB, text/plain)
2013-10-03 09:59 EDT, Thomas Haller
no flags Details

  None (edit)
Description bober 2013-10-02 14:00:48 EDT
Description of problem:
I upgrade NetworkManager to version 0.9.9.0-13.git20131001.fc20.x86_64.
After restart NetworkManager  (systemctl restart NetworkManager.service), service while crash.

I sea in logs "ERROR:bluez-manager/nm-bluez-device.c:249:pan_connection_check_create:"
When i disable bluetooth (systemctl disable bluetooth.service) and restart NetworkManager, is running again

Version-Release number of selected component:
NetworkManager-0.9.9.0-13.git20131001.fc20

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/sbin/NetworkManager --no-daemon
crash_function: _g_log_abort
executable:     /usr/sbin/NetworkManager
kernel:         3.11.2-301.fc20.x86_64
runlevel:       unknown
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 _g_log_abort at /lib64/libglib-2.0.so.0
 #3 g_assertion_message at /lib64/libglib-2.0.so.0
 #4 g_assertion_message_expr at /lib64/libglib-2.0.so.0
 #5 check_emit_usable
 #6 adapter_properties_changed
 #7 ffi_call_unix64 at /lib64/libffi.so.6
 #8 ffi_call at /lib64/libffi.so.6
 #9 g_cclosure_marshal_generic at /lib64/libgobject-2.0.so.0
 #10 g_closure_invoke at /lib64/libgobject-2.0.so.0
 #11 signal_emit_unlocked_R at /lib64/libgobject-2.0.so.0
Comment 1 bober 2013-10-02 14:00:52 EDT
Created attachment 806655 [details]
File: backtrace
Comment 2 bober 2013-10-02 14:00:55 EDT
Created attachment 806656 [details]
File: cgroup
Comment 3 bober 2013-10-02 14:00:58 EDT
Created attachment 806657 [details]
File: core_backtrace
Comment 4 bober 2013-10-02 14:01:01 EDT
Created attachment 806658 [details]
File: dso_list
Comment 5 bober 2013-10-02 14:01:04 EDT
Created attachment 806659 [details]
File: environ
Comment 6 bober 2013-10-02 14:01:07 EDT
Created attachment 806660 [details]
File: limits
Comment 7 bober 2013-10-02 14:01:11 EDT
Created attachment 806661 [details]
File: maps
Comment 8 bober 2013-10-02 14:01:14 EDT
Created attachment 806662 [details]
File: open_fds
Comment 9 bober 2013-10-02 14:01:17 EDT
Created attachment 806663 [details]
File: proc_pid_status
Comment 10 bober 2013-10-02 14:01:20 EDT
Created attachment 806664 [details]
File: var_log_messages
Comment 11 Jirka Klimes 2013-10-03 03:35:25 EDT
I managed to reproduce. The problem was as incorrect assertion.
Thomas has fixed that upstream:
f4557256ea9d0912dbd292c5431c41a2073e2cdc
bluez: fix creation of NAP connection for bluez device
Comment 13 Thomas Haller 2013-10-03 09:55:04 EDT
You can find a test build (scratch-build) at http://koji.fedoraproject.org/koji/taskinfo?taskID=6020781 . This test version contains the mentioned patch f4557256ea9d0912dbd292c5431c41a2073e2cdc.




Btw. a temporary workaround would be to create the connection for the bluetooth device on disk, so that NetworkManager does not try to create one (and does not crash). Something like below (adjust 'bdaddr' accordingly):



[connection]
id=Bluetooth Network
uuid=eea8516c-b73f-43c0-9dcf-f18f03979fd3
type=bluetooth
autoconnect=false

[bluetooth]
bdaddr=00:11:22:33:44:55
type=panu

[ipv6]
method=auto

[ipv4]
method=auto
may-fail=false
Comment 14 Thomas Haller 2013-10-03 09:59:18 EDT
Created attachment 807091 [details]
[PATCH] koji commit for NetworkManager-0.9.9.0-13test.git20131001.fc20.src.rpm

(In reply to Thomas Haller from comment #13)

This is the patch for the koji build of the before mentioned scratch build.
Comment 15 Fedora Update System 2013-10-03 15:51:34 EDT
NetworkManager-0.9.9.0-14.git20131003.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.9.0-14.git20131003.fc20
Comment 16 Fedora Update System 2013-10-04 21:43:07 EDT
Package NetworkManager-0.9.9.0-14.git20131003.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.9.0-14.git20131003.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18316/NetworkManager-0.9.9.0-14.git20131003.fc20
then log in and leave karma (feedback).
Comment 17 Fedora Update System 2013-10-09 10:52:22 EDT
NetworkManager-0.9.9.0-14.git20131003.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Thomas Haller 2013-10-30 16:25:24 EDT
*** Bug 1015543 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.