Bug 101481 - A number of processes crash during boot, apparently in kernel code
Summary: A number of processes crash during boot, apparently in kernel code
Status: CLOSED DUPLICATE of bug 99507
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-01 18:00 UTC by Philip Beevers
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:57:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot output of the machine. (15.11 KB, text/plain)
2003-08-01 18:02 UTC, Philip Beevers
no flags Details

Description Philip Beevers 2003-08-01 18:00:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030709

Description of problem:
Boot output appears normal, until a kernel stack trace appears, apparently due
to some sort of crash (see attachments).

This is repeated a number of times, from a number of processes, during boot.
Sometimes the system appears to complete the boot sequence, and sometimes it hangs.

Version-Release number of selected component (if applicable):
kernel-2.4.21-1.1931.2.349.2.2.ent

How reproducible:
Always

Steps to Reproduce:
1. Install taroon beta on my Athlon XP-based HP Pavilion a110.uk
2. Reboot
    

Actual Results:  See description.

Expected Results:  System should have booted normally.

Additional info:

The machine has the AC97 sound hardware which is noted in the release notes as
causing problems, but the release notes only mention Intel chipsets (this
machine has a VIA chipset). I've tried disabling the sound hardware in the BIOS,
which is spotted by kudzu but doesn't fix the problem.

Machine has two CD drives - a CD-ROM and a CD-RW - in addition to two IDE hard
drives.

System runs RH9 with no problems.

Comment 1 Philip Beevers 2003-08-01 18:02:39 UTC
Created attachment 93336 [details]
Boot output of the machine.

This is the output from when the machine just booted.

Comment 2 Bill Nottingham 2003-08-01 19:15:58 UTC

*** This bug has been marked as a duplicate of 101040 ***

Comment 3 Ernie Petrides 2003-08-01 23:57:11 UTC
The original bug report is #99507, so I just reopened this
temporarily to reassign the duplicate designation.

The problem has been resolved with a change to the Athlon-specific
prefetch routine to test for NULL addresses.  The change is applied by
linux-2.4.18-smallpatches.patch to include/asm-i386/processor.h, and
will be incorporated into any kernel version 2.4.21-1.1931.2.364 or
later (and will thus be part of Taroon B2).

*** This bug has been marked as a duplicate of 99507 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:57:56 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.