Bug 1014831 - slapo-constraint causes modify operations to fail
slapo-constraint causes modify operations to fail
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openldap (Show other bugs)
6.4
All All
unspecified Severity medium
: rc
: ---
Assigned To: Jan Synacek
David Spurek
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-02 17:27 EDT by Arpit Tolani
Modified: 2015-03-02 00:28 EST (History)
5 users (show)

See Also:
Fixed In Version: openldap-2.4.39-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 00:57:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch slapo-constraint -- include upstream fixes (2.53 KB, patch)
2013-11-13 05:22 EST, Jan Synacek
no flags Details | Diff

  None (edit)
Description Arpit Tolani 2013-10-02 17:27:28 EDT
Description of problem:
When the constraint overlay is enabled and the restrict parameter is configured, this can cause all modify operations to fail on the affected entries.


Version-Release number of selected component (if applicable):
openldap-servers-2.4.23-26

How reproducible:
100%

Steps to reproduce:
- install openldap-servers-2.4.23-26 or later
- enable the constraint overlay
- configure a constraint attribute with the restrict parameter set. Example:
uid regex ^[[:alnum:]-]+$  restrict="ldap:///ou=people,dc=example,dc=com??sub?(objectClass=inetOrgPerson)"
- add an entry which is included in the restriction set in the constraint, and which contains the attribute (uid in the example). Example: uid=tuser,ou=people,dc=exanoke,dc=com
- try to add a different attribute. I have tested with carLicense. Adding the attribute fails.
- if the constraint is removed, carLicense is added and the constraint on uid is enabled again, carLicense cannot be modified.

Actual results:
all modify options fails.

Expected results:


Additional info:

http://www.openldap.org/its/index.cgi?findid=7168
http://www.openldap.org/its/index.cgi/Software%20Bugs?id=7340;selectid=7340;usearchives=1
Comment 1 Jan Synacek 2013-11-13 05:22:09 EST
Created attachment 823337 [details]
Patch slapo-constraint -- include upstream fixes
Comment 11 errata-xmlrpc 2014-10-14 00:57:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1426.html

Note You need to log in before you can comment on or make changes to this bug.