Bug 101487 - LTC3761-qla2300 driver cannot initialize adapters during install
LTC3761-qla2300 driver cannot initialize adapters during install
Status: CLOSED DUPLICATE of bug 99362
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Tom Coughlan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-01 14:48 EDT by IBM Bug Proxy
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description IBM Bug Proxy 2003-08-01 14:48:42 EDT
The following has be reported by IBM LTC:  
qla2300 driver cannot initialize adapters during install
Please fill in each of the sections below.

Hardware Environment: IBM x440 8way, 64GB RAM, 8 Qlogic FC 2310 adapters

Software Environment: RHAS30 Beta 1 install


Steps to Reproduce:
1.With specified hardware environment begin beta install. System reaches point 
where it is loading qla2xxx driver and remains there for > 10 minutes. The 
qlogic adapters are discovered but attempts to communicate with them appear to 
return errors. The driver times out and reissues the commands until iterations 
are exhausted.
2.
3.

Actual Results: Had to remove the qla2310 adapters to complete the install. 

Expected Results: Should have been able to initialize the adapters during 
install.

Additional Information: Once the install issue is worked around and the distro 
is installed, on subsequent reboots the qla2310 adapters are discovered and 
initialized properly. Since this is a Summit chipset machine could it be the 
installation kernel isn't setting up the apic correctly?
Comment 1 Tom Coughlan 2003-08-01 16:00:25 EDT
Arjan, can you look at this while I am on vacation?
Comment 2 Arjan van de Ven 2003-08-01 16:06:21 EDT
This is a dupe of 99362

*** This bug has been marked as a duplicate of 99362 ***
Comment 3 Arjan van de Ven 2003-08-01 16:20:35 EDT
Fwiw the installer doesn't use apics at all but PIC mode via the $PIR table
Comment 4 IBM Bug Proxy 2003-08-07 10:46:09 EDT
------ Additional Comments From mksully@us.ibm.com  2003-07-08 08:10 -------
Hardware environment should read 16GB ram... 
Comment 5 IBM Bug Proxy 2003-08-30 10:22:54 EDT
------ Additional Comments From mksully@us.ibm.com  2003-30-08 09:27 -------
Tried on RHAS 3.0 Build 399 with only a single CEC enabled. It failed in the same way. 
Comment 6 Arjan van de Ven 2003-08-30 10:36:43 EDT
was the controller in an RXE extension enclosure ?
Comment 7 IBM Bug Proxy 2003-08-30 13:04:23 EDT
------ Additional Comments From mksully@us.ibm.com  2003-30-08 10:30 -------
Tried to reverify on build 399. I disabled so as to run with a single CEC. It 
still fails with timeouts on the qlogic adapters. 
Comment 8 IBM Bug Proxy 2003-08-30 13:07:01 EDT
------ Additional Comments From mksully@us.ibm.com  2003-30-08 12:48 -------
As an workaround alternative to removing the qla adapters during the install 
you could use the "linux noprobe" option and avoid even trying to initialize 
the qla2xxx driver. 
Comment 9 IBM Bug Proxy 2003-08-30 13:27:30 EDT
------ Additional Comments From mksully@us.ibm.com  2003-30-08 13:10 -------
Yes, two of the qla2310 adapters were in an RXE expansion enclosure. 
Comment 10 IBM Bug Proxy 2003-09-25 17:01:43 EDT
------ Additional Comments From khoa@us.ibm.com  2003-25-09 16:38 -------
Since this will be documented in a release note (install on a minimally
configured system with one CEC and no RXE expansion, then plug in the rest
of the system after install), I'd like to set the resolution of this bug
to "Documented".  See the note above from Red Hat for more details on
the available options and long-term plan. 
Comment 11 Red Hat Bugzilla 2006-02-21 13:57:56 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.