Bug 101490 - at boot, fsck.ext3 spend *lot of time* do nothing
Summary: at boot, fsck.ext3 spend *lot of time* do nothing
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: e2fsprogs   
(Show other bugs)
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Jay Turner
URL: http://e2fsprogs.sourceforge.net/e2fs...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-01 19:00 UTC by acount closed by user
Modified: 2015-01-08 00:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-01 20:28:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description acount closed by user 2003-08-01 19:00:07 UTC
Description of problem:

Theodore Ts'o has fixed into 1.34:
"Fixed a bug introduced in E2fsprogs 1.30 which caused fsck to spin in a tight
loop while waiting for a child fsck to exit in some cases. This burns CPU times
which slows down the low-level filesystem check."



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Florian La Roche 2003-08-01 20:28:29 UTC
Rawhide should soon have 1.34-1.

Thanks,

Florian La Roche


Comment 2 Robert M. Riches Jr. 2004-02-01 00:12:51 UTC
Any word on when/whether this will be released as production
for RHL 9?  With RHL 8.0, my main machine never took more
than about 5 minutes to check filesystems after "shutdown
-rF now" or a power drop or other unplanned shutdown.  Now,
RHL 9 takes 50 minutes (!) to check the filesystems--just a
little less than an hour.

I just tried
http://rawhide.redhat.com/pub/redhat/linux/9/en/os/i386/RedHat/RPMS/
and e2fsprogs-1.32-6.i386.rpm is the only e2fsprogs I see.
There are lots of references to e2fsprogs 1.34 for Fedora
but none for RHL 9 or rawhide.

If a 1.34-1 for RHL 9 can be found, what is the level of
confidence that it is safe?

Thanks.


Comment 3 Robert M. Riches Jr. 2004-02-03 18:57:26 UTC
In newsgroup comp.os.linux.redhat, P Gentry claimed
http://rpmfind.net/linux/RPM/redhat/severn/i386/e2fsprogs-1.34-1.i386.html
was the package referred to above, with such mention
implying the package was built for and safe to use
on RHL 9.

Can someone confirm that?

Thanks.


Comment 4 acount closed by user 2004-02-03 19:07:03 UTC
querida:~ $ rpm -q e2fsprogs
e2fsprogs-1.34-1
querida:~ $ cat /etc/redhat-release
Red Hat Linux release 9 (Shrike)

I got the src.rpm time ago(Wed 06 Aug 2003 10:17:28 PM CEST) from
rawhide and it works for me without problems until today.


Note You need to log in before you can comment on or make changes to this bug.