Bug 1014916 - Show only selected post-install configuration options on post-install summary screen
Show only selected post-install configuration options on post-install summary...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ER5
: EAP 6.2.0
Assigned To: Miles Tjandrawidjaja
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 02:26 EDT by Petr Kremensky
Modified: 2014-09-03 00:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:19:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Post-install summary screen with unused configuration (86.07 KB, image/png)
2013-10-03 02:26 EDT, Petr Kremensky
no flags Details

  None (edit)
Description Petr Kremensky 2013-10-03 02:26:20 EDT
Created attachment 806881 [details]
Post-install summary screen with unused configuration

Description of problem:
 Post install summary screen shouldn't show all post-install configuration if we uncheck all options on Post-install Configuration screen. I would prefer to skip this screen once none of post-install options is checked.

Version-Release number of selected component (if applicable):
 EAP 6.2.0.ER3

How reproducible:
 always

Steps to Reproduce:
 1. Run gui installation, go to Post-Install Configuration screen
 2. Select "Perform additional post-install configuration
 3. Check some of post-install configuration
 4. Continue to Post Install configuration summary screen
 5. Return to Post-Install Configuration screen and uncheck all post-install options you chose in step 3. (but leave "Perform additional post-install caonfiguration" radio button pushed)
 6. Press next button

Actual results:
 Post Install configuration summary screen is shown with all configuration options we've made (see attachment). 

Expected results:
 Only:
Post Install Configuration
Vault Configuration: off
SSL Configuration: off
LDAP Configuration selected: off
Install Infinispan cache: off
Install security-somain: off
JDBC Configuration selected: off
datasource.install: off

is shown or this screen is skipped (I'd prefer this option if IZ-pack allow us to do so).

Additional info:
This could be seen as two issues:
1) skip Summary screen if none of post-configuration checkboxes is checked
2) do not show the configuration of unchecked options on Summary scree (eg. we check two post-install options, on summary screen we decide to go back and uncheck one of them, but summary screen still show both configurations)
Comment 1 Petr Kremensky 2013-10-03 02:29:48 EDT
There is actually security domain set to ON on the attachment 806881 [details] (my mistake), but even if it would be OFF the rest of the screen would remain the same.
Comment 2 Miles Tjandrawidjaja 2013-10-04 09:55:50 EDT
Post install summary panel will now only show the options you have checked, as described in the expected results.

I'm not sure about skipping the summary panel if none of the post-configuration checkboxes are checked, but the user had selected to perform a post-installation. If the user intended to do post-install but selects nothing, I think it should explicitly be shown that nothing has been configured, it also gives the user a chance to hit the previous button incase they want to change their mind.

http://git.app.eng.bos.redhat.com/izpack.git/commit/?h=izpack-wip&id=95e3fd36f8f7692584a843c4eb7fa4a566c10b58
Comment 3 Petr Kremensky 2013-10-08 03:15:07 EDT
Yes, that's a really good point.

Verified on EAP 6.2.0.ER5 installer.

Note You need to log in before you can comment on or make changes to this bug.