Bug 1015003 - kernel version 3.11.2-201.fc19.x86_64 NFS server is broken
kernel version 3.11.2-201.fc19.x86_64 NFS server is broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: nfs-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 05:46 EDT by Tomasz Sterna
Modified: 2014-01-04 09:26 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-04 09:26:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Sterna 2013-10-03 05:46:50 EDT
User-Agent:       Opera/9.80 (X11; Linux x86_64) Presto/2.12.388 Version/12.16
Build Identifier: 

After upgrading to kernel-3.11.2-201.fc19.x86_64 NFS server stopped working.

Mount requests loop at:
[...]
paź 03 10:16:59 westeros-4-37.dcc rpc.mountd[693]: authenticated mount request from 192.168.4.172:980 for /usr/local/dcc/nmc-2.0/sh4/vip1853pltv/rootfs (/usr/local/dcc)
paź 03 10:17:00 westeros-4-37.dcc rpc.mountd[693]: authenticated mount request from 192.168.4.172:938 for /usr/local/dcc/nmc-2.0/sh4/vip1853pltv/rootfs (/usr/local/dcc)
paź 03 10:17:01 westeros-4-37.dcc rpc.mountd[693]: authenticated mount request from 192.168.4.172:841 for /usr/local/dcc/nmc-2.0/sh4/vip1853pltv/rootfs (/usr/local/dcc)
paź 03 10:17:02 westeros-4-37.dcc rpc.mountd[693]: authenticated mount request from 192.168.4.172:702 for /usr/local/dcc/nmc-2.0/sh4/vip1853pltv/rootfs (/usr/local/dcc)
paź 03 10:17:03 westeros-4-37.dcc rpc.mountd[693]: authenticated mount request from 192.168.4.172:954 for /usr/local/dcc/nmc-2.0/sh4/vip1853pltv/rootfs (/usr/local/dcc)
paź 03 10:17:04 westeros-4-37.dcc rpc.mountd[693]: authenticated mount request from 192.168.4.172:975 for /usr/local/dcc/nmc-2.0/sh4/vip1853pltv/rootfs (/usr/local/dcc)
paź 03 10:17:05 westeros-4-37.dcc rpc.mountd[693]: authenticated mount request from 192.168.4.172:977 for /usr/local/dcc/nmc-2.0/sh4/vip1853pltv/rootfs (/usr/local/dcc)
paź 03 10:17:06 westeros-4-37.dcc rpc.mountd[693]: authenticated mount request from 192.168.4.172:669 for /usr/local/dcc/nmc-2.0/sh4/vip1853pltv/rootfs (/usr/local/dcc)
paź 03 10:17:07 westeros-4-37.dcc rpc.mountd[693]: authenticated mount request from 192.168.4.172:915 for /usr/local/dcc/nmc-2.0/sh4/vip1853pltv/rootfs (/usr/local/dcc)
paź 03 10:17:08 westeros-4-37.dcc rpc.mountd[693]: authenticated mount request from 192.168.4.172:858 for /usr/local/dcc/nmc-2.0/sh4/vip1853pltv/rootfs (/usr/local/dcc)
[...]

Reproducible: Always




After booting kernel version 3.10.11-200.fc19.x86_64 NFS mounting works fine again.
Comment 1 J. Bruce Fields 2013-10-03 16:01:38 EDT
What's your client, and what version of the NFS protocol are you using?
Comment 2 Tomasz Sterna 2013-10-04 05:52:33 EDT
The client is STLinux:
# uname -a
Linux stb 2.6.23.17-stm23-0123 #1 PREEMPT Tue Sep 10 16:42:52 CEST 2013 sh4 GNU/Linux

using whatever version it defaults to (my guess v3) while mounting rootfs over NFS.
Comment 3 J. Bruce Fields 2013-11-01 10:35:03 EDT
(In reply to Tomasz Sterna from comment #2)
> The client is STLinux:
> # uname -a
> Linux stb 2.6.23.17-stm23-0123 #1 PREEMPT Tue Sep 10 16:42:52 CEST 2013 sh4
> GNU/Linux
> 
> using whatever version it defaults to (my guess v3) while mounting rootfs
> over NFS.

Double-check that, it might be v2, in which case you need to edit /etc/sysconfig/nfs on the server to pass -V2 to rpc.nfsd, or fix the client-side configuration.
Comment 4 Tomasz Sterna 2013-11-04 04:15:28 EST
Adding RPCNFSDARGS="-V2" helped and mounting succeeded.
Thanks. :-)

So, some behavior was changed between these two kernel versions.
Should it be documented or defaulted differently?
Comment 5 Justin M. Forbes 2014-01-03 17:04:03 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.12.6-200.fc19.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 20, and are still experiencing this issue, please change the version to Fedora 20.

If you experience different issues, please open a new bug report for those.

Note You need to log in before you can comment on or make changes to this bug.