Bug 1015014 - [RHSC] Error message displayed when an unauthorized user tries to optimize a volume for virt store, needs improvement.
[RHSC] Error message displayed when an unauthorized user tries to optimize a ...
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Ramesh N
Shruti Sampat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 06:01 EDT by Shruti Sampat
Modified: 2015-08-28 06:43 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-28 06:43:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (178.56 KB, image/png)
2013-10-03 06:01 EDT, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21461 None None None Never

  None (edit)
Description Shruti Sampat 2013-10-03 06:01:56 EDT
Created attachment 806999 [details]
screenshot

Description of problem:
-----------------------
When a user of RHSC, who is unauthorized to manipulate volumes, tries to optimize a volume for use as a virt store, the error dialog seen needs to be improved. 

Currently, the error seen looks like this -

Error while executing action:

Action 1:

    User is not authorized to perform this action.

Action 2:

    User is not authorized to perform this action.

Action 3:

    User is not authorized to perform this action.


The dialog should not show 3 actions as above. There should be a single error message which says that the user is not authorized to perform this action.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.1-0.0.1.master.el6ev 

How reproducible:
Always

Steps to Reproduce:
1. Login as a user who is not authorized to manipulate volumes.
2. Select a volume and click on Optimize for virt store.

Actual results:
The above described error message is seen.

Expected results:
Error message needs improvement.

Additional info:
Screenshot attached.
Comment 2 Dusmant 2013-11-12 12:04:28 EST
Lets try to fix this in Corbett. This warning looks ugly.
Comment 3 Dusmant 2013-11-24 23:57:37 EST
Fixing this warning is becoming more complex and the right way would be to add a new BLL command in the engine side. And that may take more time. 

Hence we need to remove this bug out of Corbett list.
Comment 5 Dusmant 2015-08-28 06:43:25 EDT
We are not planning to fix it. Hence closing this BZ. If you think, it's applicable for 3.x release and would have an impact on customer, pls. open up a new BZ with the appropriate version. Thanks, -Dusmant

Note You need to log in before you can comment on or make changes to this bug.