Bug 1015057 - org delete fails if it has manifest imported
org delete fails if it has manifest imported
Status: CLOSED DUPLICATE of bug 1015679
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Adam Price
Katello QA List
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 07:36 EDT by Garik Khachikyan
Modified: 2015-01-04 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 15:50:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs. (689.22 KB, application/gzip)
2013-10-03 07:36 EDT, Garik Khachikyan
no flags Details

  None (edit)
Description Garik Khachikyan 2013-10-03 07:36:15 EDT
Created attachment 807020 [details]
logs.

Description of problem:
seems to me the old times are back again: unable to remove the org if it has a manifest imported (and synced for my case).

More investigation needed (will comment soon) if the reason is having an entry in notifications table or not.

this is a REAL issue for our automation (manifests can not be reused and scenarios are failing down) as well as it's a clear regression. Needs an immediate fix , please. tyia.

Version-Release number of selected component (if applicable):
candlepin-0.8.25-1.el6sam.noarch
candlepin-cert-consumer-artemis.usersys.redhat.com-1.0-1.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.25-1.el6sam.noarch
candlepin-tomcat6-0.8.25-1.el6sam.noarch
createrepo-0.9.9-21.2.pulp.el6sat.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-1.4.6-15.el6sat.noarch
katello-agent-1.4.4-2.el6sat.noarch
katello-all-1.4.6-15.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-cli-1.4.3-15.el6sat.noarch
katello-cli-common-1.4.3-15.el6sat.noarch
katello-common-1.4.6-15.el6sat.noarch
katello-configure-1.4.5-8.el6sat.noarch
katello-configure-foreman-1.4.5-8.el6sat.noarch
katello-configure-foreman-proxy-1.4.5-8.el6sat.noarch
katello-foreman-all-1.4.6-15.el6sat.noarch
katello-glue-candlepin-1.4.6-15.el6sat.noarch
katello-glue-elasticsearch-1.4.6-15.el6sat.noarch
katello-glue-pulp-1.4.6-15.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-selinux-1.4.4-4.el6sat.noarch
m2crypto-0.21.1.pulp-8.el6sat.x86_64
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-katello-plugins-0.2-1.el6sat.noarch
pulp-nodes-common-2.3.0-0.14.alpha.el6sat.noarch
pulp-nodes-parent-2.3.0-0.14.alpha.el6sat.noarch
pulp-puppet-plugins-2.3.0-0.14.alpha.el6sat.noarch
pulp-rpm-handlers-2.3.0-0.14.alpha.el6sat.noarch
pulp-rpm-plugins-2.3.0-0.14.alpha.el6sat.noarch
pulp-selinux-2.3.0-0.14.alpha.el6sat.noarch
pulp-server-2.3.0-0.14.alpha.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
python-oauth2-1.5.170-3.pulp.el6sat.noarch
python-pulp-agent-lib-2.3.0-0.14.alpha.el6sat.noarch
python-pulp-bindings-2.3.0-0.14.alpha.el6sat.noarch
python-pulp-common-2.3.0-0.14.alpha.el6sat.noarch
python-pulp-puppet-common-2.3.0-0.14.alpha.el6sat.noarch
python-pulp-rpm-common-2.3.0-0.14.alpha.el6sat.noarch
python-qpid-0.18-5.el6_4.noarch
qpid-cpp-client-0.14-22.el6_3.x86_64
qpid-cpp-client-ssl-0.14-22.el6_3.x86_64
qpid-cpp-server-0.14-22.el6_3.x86_64
qpid-cpp-server-ssl-0.14-22.el6_3.x86_64
ruby193-rubygem-foreman-katello-engine-0.0.8-6.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.5-2.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch
ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
signo-katello-0.0.20-3.el6sat.noarch

How reproducible:
always.

Steps to Reproduce:
1.create an org, import manifest, enable a repo and do sync.
2.now do in CLI: org delete
3.

Actual results:
Organization [ garik ] deletion failed::     

Expected results:
no errors, and which is more important: the manifest have to be reusable for later orgs.

Additional info:
logs attached.
Comment 2 Garik Khachikyan 2013-10-03 07:51:48 EDT
confirm: manifest import (existence) is NOT the root cause rather than rows in noticies seems.

I had performed several actions (prepared a custom repo; through content view made it available in an environment and registered a system to that env.) and then:

delete of that org fails (same output: "Organization [ notices ] deletion failed::   "
Comment 4 Walden Raines 2013-10-16 15:50:51 EDT
Marking as duplicate of #1015679 since that is already assigned to Petr.

*** This bug has been marked as a duplicate of bug 1015679 ***

Note You need to log in before you can comment on or make changes to this bug.