Bug 1015113 - EAP 6.2.0 src zip POMs should not have SNAPSHOT versions
EAP 6.2.0 src zip POMs should not have SNAPSHOT versions
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Build (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Paul Gier
Pavel Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 09:15 EDT by Pavel Jelinek
Modified: 2013-10-24 16:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: Consequence: Workaround (if any): Results:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-24 16:00:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Jelinek 2013-10-03 09:15:04 EDT
POMs in jboss-eap-6.2.0.ER3-src.zip have version 7.3.0.Final-redhat-SNAPSHOT. 
Customer should not meet SNAPSHOT version of our product even in source POMs.
Comment 1 Paul Gier 2013-10-09 14:59:52 EDT
This is just how our builds are set up now, GSS is ok with this, but we can probably add docs in case there is any confusion for users.
Comment 2 Pavel Jelinek 2013-10-16 07:10:21 EDT
This should be at least mentioned in known issues part of release notes.
Comment 3 Paul Gier 2013-10-21 13:06:55 EDT
Nacking this because this change is intentional because the locally rebuilt version of a project is a SNAPSHOT, and not the actual release.  

We don't currently have any official documentation regarding how to rebuild our products from source, but if we do create such documentation, then a note about this should be added to that.
Comment 5 Paul Gier 2013-10-24 16:00:02 EDT
Closing this as not a bug because using the -SNAPSHOT version in the source artifacts is an intentional part of our build process.

Note You need to log in before you can comment on or make changes to this bug.