Bug 101517 - headers using ({ ... }) should have __extension__ markers
headers using ({ ... }) should have __extension__ markers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: glibc-kernheaders (Show other bugs)
beta1
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-02 04:10 EDT by Ngo Than
Modified: 2007-03-27 00:08 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-15 08:56:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ngo Than 2003-08-02 04:10:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
x86_64-redhat-linux-g++ -DHAVE_CONFIG_H -I. -I. -I..  -I/usr/include/cdda
-I/usr/include/kde -I/usr/lib64/qt-3.1/include -I/usr/X11R6/include  -static
-Wall -DDATADIR=\"/usr/share/apps/kaudiocreator\" -DQT_THREAD_SUPPORT 
-D_REENTRANT  -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W
-Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE
-Wcast-align -Wconversion -DNDEBUG -DNO_DEBUG -O2 -O2 -g -pipe -DNDEBUG
-fno-use-cxa-atexit -fno-exceptions -fno-check-new -DQT_CLEAN_NAMESPACE
-DQT_NO_ASCII_CAST  -c -o ripconfigimp.o `test -f 'ripconfigimp.cpp' || echo
'./'`ripconfigimp.cpp
In file included from /usr/include/linux/byteorder/little_endian.h:11,
                 from /usr/include/asm-x86_64/byteorder.h:30,
                 from /usr/include/asm/byteorder.h:4,
                 from /usr/include/linux/cdrom.h:14,
                 from cdconfigimp.cpp:78:
/usr/include/linux/byteorder/swab.h: In function `const __u16 __fswab16(short 
   unsigned int)':
/usr/include/linux/byteorder/swab.h:133: error: ISO C++ forbids braced-groups 
   within expressions
/usr/include/linux/byteorder/swab.h:133: error: ISO C++ forbids braced-groups 
   within expressions
/usr/include/linux/byteorder/swab.h: In function `__u16 __swab16p(__u16*)':
/usr/include/linux/byteorder/swab.h:137: error: ISO C++ forbids braced-groups 
   within expressions
/usr/include/linux/byteorder/swab.h:137: error: ISO C++ forbids braced-groups 
   within expressions
/usr/include/linux/byteorder/swab.h: In function `void __swab16s(__u16*)':
/usr/include/linux/byteorder/swab.h:141: error: ISO C++ forbids braced-groups 
   within expressions
/usr/include/linux/byteorder/swab.h:141: error: ISO C++ forbids braced-groups 
   within expressions
/usr/include/c++/3.3/bits/stl_map.h: At top level:
/usr/include/cdda/cdda_interface.h:159: warning: `char*strerror_tr[12]' defined 
   but not used

Version-Release number of selected component (if applicable):
glibc-kernheaders-2.4-8.24

How reproducible:
Always

Steps to Reproduce:
x86_64-redhat-linux-g++ -DHAVE_CONFIG_H -I. -I. -I..  -I/usr/include/cdda
-I/usr/include/kde -I/usr/lib64/qt-3.1/include -I/usr/X11R6/include  -static
-Wall -DDATADIR=\"/usr/share/apps/kaudiocreator\" -DQT_THREAD_SUPPORT 
-D_REENTRANT  -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W
-Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE
-Wcast-align -Wconversion -DNDEBUG -DNO_DEBUG -O2 -O2 -g -pipe -DNDEBUG
-fno-use-cxa-atexit -fno-exceptions -fno-check-new -DQT_CLEAN_NAMESPACE
-DQT_NO_ASCII_CAST  -c -o ripconfigimp.o `test -f 'ripconfigimp.cpp' || echo
'./'`ripconfigimp.cpp
In file included from /usr/include/linux/byteorder/little_endian.h:11,
                 from /usr/include/asm-x86_64/byteorder.h:30,
                 from /usr/include/asm/byteorder.h:4,
                 from /usr/include/linux/cdrom.h:14,
                 from cdconfigimp.cpp:78:
/usr/include/linux/byteorder/swab.h: In function `const __u16 __fswab16(short 
   unsigned int)':
/usr/include/linux/byteorder/swab.h:133: error: ISO C++ forbids braced-groups 
   within expressions
/usr/include/linux/byteorder/swab.h:133: error: ISO C++ forbids braced-groups 
   within expressions
/usr/include/linux/byteorder/swab.h: In function `__u16 __swab16p(__u16*)':
/usr/include/linux/byteorder/swab.h:137: error: ISO C++ forbids braced-groups 
   within expressions
/usr/include/linux/byteorder/swab.h:137: error: ISO C++ forbids braced-groups 
   within expressions
/usr/include/linux/byteorder/swab.h: In function `void __swab16s(__u16*)':
/usr/include/linux/byteorder/swab.h:141: error: ISO C++ forbids braced-groups 
   within expressions
/usr/include/linux/byteorder/swab.h:141: error: ISO C++ forbids braced-groups 
   within expressions
/usr/include/c++/3.3/bits/stl_map.h: At top level:
/usr/include/cdda/cdda_interface.h:159: warning: `char*strerror_tr[12]' defined 
   but not used


Actual Results:  rebuild kdemultimedia failed

Expected Results:  it should build

Additional info:

it works by removing -pedantic in CXXFLAGS
Comment 1 Arjan van de Ven 2003-08-02 06:54:10 EDT
including these private headers in C++ code is always a hazard.....
Comment 2 David Woodhouse 2005-04-15 08:56:41 EDT
Looks like this was fixed a while ago anyway. cdrom.h is one of the few cases
where it's vaguely OK to share a kernel header -- that's one of the headers
which the kernel _should_ be exporting. 

Note You need to log in before you can comment on or make changes to this bug.