Bug 1015184 - showmount timesout on fetching export information
showmount timesout on fetching export information
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: rjoseph
: ZStream
Depends On: 981035
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 11:13 EDT by rjoseph
Modified: 2014-04-17 07:49 EDT (History)
9 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 981035
Environment:
Last Closed: 2014-04-17 07:49:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-10-03 11:28:00 EDT
REVIEW: http://review.gluster.org/6030 (NFS: showmount timesout on fetching export list) posted (#3) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 2 Anand Avati 2013-10-04 01:37:20 EDT
REVIEW: http://review.gluster.org/6030 (NFS: showmount timesout on fetching export list) posted (#4) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 3 Anand Avati 2013-10-04 02:14:38 EDT
REVIEW: http://review.gluster.org/6030 (NFS: showmount timesout on fetching export list) posted (#5) for review on master by Rajesh Joseph (rjoseph@redhat.com)
Comment 4 Anand Avati 2013-10-04 23:15:47 EDT
COMMIT: http://review.gluster.org/6030 committed in master by Anand Avati (avati@redhat.com) 
------
commit 1f6b0f5cfc5abebe3a8facfb8b72e5554c1314d2
Author: Rajesh Joseph <rjoseph@redhat.com>
Date:   Thu Oct 3 15:08:34 2013 +0530

    NFS: showmount timesout on fetching export list
    
    Bug: 1015184
    
    Issue:  showmount timesout on fetching export list. Socket writev
            function is failing.
    Cause:  XDR encoding of export list is failing. The calling function
            without checking the error returned by xdr_serialize_exports
            function is going ahead and writting into the socket causing
            the NFS process to hang. xdr_serialize_exports function returns
            -1 on error and message length on success.
    Fix:    Caller should check if the function is returning -1 (error) or
            not before proceeding.
    
    Change-Id: Ic3a5a9356e47b2ac938dd3e429cf2b71c0a0c715
    Signed-off-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-on: http://review.gluster.org/6030
    Reviewed-by: Santosh Pradhan <spradhan@redhat.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 5 Niels de Vos 2014-04-17 07:49:08 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.