Bug 1015307 - [abrt] NetworkManager-0.9.9.0-13.git20131001.fc20: _g_log_abort: Process /usr/sbin/NetworkManager was killed by signal 6 (SIGABRT)
[abrt] NetworkManager-0.9.9.0-13.git20131001.fc20: _g_log_abort: Process /usr...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
abrt_hash:472d10ef2080653b0800b4ca54a...
:
: 1014991 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 17:34 EDT by D. Charles Pyle
Modified: 2013-11-08 06:01 EST (History)
3 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.9.0-14.git20131003.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 10:53:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (15.08 KB, text/plain)
2013-10-03 17:34 EDT, D. Charles Pyle
no flags Details
File: cgroup (152 bytes, text/plain)
2013-10-03 17:34 EDT, D. Charles Pyle
no flags Details
File: core_backtrace (11.54 KB, text/plain)
2013-10-03 17:34 EDT, D. Charles Pyle
no flags Details
File: dso_list (4.16 KB, text/plain)
2013-10-03 17:34 EDT, D. Charles Pyle
no flags Details
File: environ (186 bytes, text/plain)
2013-10-03 17:34 EDT, D. Charles Pyle
no flags Details
File: limits (1.29 KB, text/plain)
2013-10-03 17:34 EDT, D. Charles Pyle
no flags Details
File: maps (20.35 KB, text/plain)
2013-10-03 17:34 EDT, D. Charles Pyle
no flags Details
File: open_fds (2.44 KB, text/plain)
2013-10-03 17:34 EDT, D. Charles Pyle
no flags Details
File: proc_pid_status (899 bytes, text/plain)
2013-10-03 17:34 EDT, D. Charles Pyle
no flags Details
File: var_log_messages (8.92 KB, text/plain)
2013-10-03 17:34 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2013-10-03 17:34:24 EDT
Description of problem:
I do not know the cause of the problem but this has been happening every several minutes or so since this late morning.  The app crashes.  I get a message about it, and this is the first time I have been able to send anything up about it.  I have tried reinstalling the network-manager-applet but keep getting Yumex crashes and python errors.  I also see complaints from Yumex and other applications that state that I have no network connection even though I still do after the crashes.

Version-Release number of selected component:
NetworkManager-0.9.9.0-13.git20131001.fc20

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        /usr/sbin/NetworkManager --no-daemon
crash_function: _g_log_abort
executable:     /usr/sbin/NetworkManager
kernel:         3.11.2-301.fc20.x86_64
runlevel:       unknown
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (5 frames)
 #2 _g_log_abort at gmessages.c:255
 #5 nm_ip6_config_replace
 #6 nm_device_set_ip6_config
 #7 ip6_config_merge_and_apply
 #8 queued_ip_config_change
Comment 1 D. Charles Pyle 2013-10-03 17:34:27 EDT
Created attachment 807289 [details]
File: backtrace
Comment 2 D. Charles Pyle 2013-10-03 17:34:29 EDT
Created attachment 807290 [details]
File: cgroup
Comment 3 D. Charles Pyle 2013-10-03 17:34:32 EDT
Created attachment 807291 [details]
File: core_backtrace
Comment 4 D. Charles Pyle 2013-10-03 17:34:36 EDT
Created attachment 807292 [details]
File: dso_list
Comment 5 D. Charles Pyle 2013-10-03 17:34:38 EDT
Created attachment 807293 [details]
File: environ
Comment 6 D. Charles Pyle 2013-10-03 17:34:40 EDT
Created attachment 807294 [details]
File: limits
Comment 7 D. Charles Pyle 2013-10-03 17:34:43 EDT
Created attachment 807295 [details]
File: maps
Comment 8 D. Charles Pyle 2013-10-03 17:34:46 EDT
Created attachment 807296 [details]
File: open_fds
Comment 9 D. Charles Pyle 2013-10-03 17:34:48 EDT
Created attachment 807297 [details]
File: proc_pid_status
Comment 10 D. Charles Pyle 2013-10-03 17:34:50 EDT
Created attachment 807298 [details]
File: var_log_messages
Comment 11 Fedora Update System 2013-10-04 07:32:51 EDT
NetworkManager-0.9.9.0-14.git20131003.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.9.0-14.git20131003.fc20
Comment 12 Jirka Klimes 2013-10-04 07:37:54 EDT
I think it was fixed by this upstream commit:
commit c4035ead5fcf2b6ee691c781f2808d77de124591
Author: Dan Williams <dcbw@redhat.com>
Date:   Thu Oct 3 13:13:41 2013 -0500

core: fix nm_ip6_config_replace() nameserver address comparison

You can install and test the new update containing the fix (comment #11).
Comment 13 D. Charles Pyle 2013-10-04 12:28:45 EDT
I had all sorts of dependency issues trying to get this installed but ended up using rpm -Uvh --force --nodeps to force the installation.  Rebooted after forced installation and I am no longer seeing the above errors so far.
Comment 14 Fedora Update System 2013-10-04 21:43:32 EDT
Package NetworkManager-0.9.9.0-14.git20131003.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.9.0-14.git20131003.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18316/NetworkManager-0.9.9.0-14.git20131003.fc20
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2013-10-09 10:53:14 EDT
NetworkManager-0.9.9.0-14.git20131003.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Jirka Klimes 2013-11-08 06:01:42 EST
*** Bug 1014991 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.