Bug 101531 - emulate rawmode for keycode 272 (fixed upstream)
Summary: emulate rawmode for keycode 272 (fixed upstream)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel   
(Show other bugs)
Version: beta1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-02 21:41 UTC by Joel
Modified: 2015-01-04 22:02 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-14 18:58:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joel 2003-08-02 21:41:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030703 Galeon/1.3.7

Description of problem:
logitech marble plugged in thru ps/2 to usb adapter produces
copious errors of the form:

Aug  2 17:08:34 user-0c93732 kernel: keyboard.c: can't emulate rawmode for
keycode 274
Aug  2 17:08:34 user-0c93732 kernel: keyboard.c: can't emulate rawmode for
keycode 274
Aug  2 17:08:40 user-0c93732 kernel: keyboard.c: can't emulate rawmode for
keycode 272
Aug  2 17:08:53 user-0c93732 last message repeated 9 times
Aug  2 17:08:54 user-0c93732 kernel: keyboard.c: can't emulate rawmode for
keycode 274

when pressing any of the mouse buttons.

This should be fixed upstream.  A patch is at:

http://www.spinics.net/lists/kernel/msg196539.html
and seems to be accepted
http://www.spinics.net/lists/kernel/msg196705.html:



Version-Release number of selected component (if applicable):
kernel-20.1.2024.2.1.nptl 

How reproducible:
Always

Steps to Reproduce:
1.  plug in ps/2 to usb adapter
2. plug logitech mouse in to that 
3.  click mouse button
    

Actual Results:  spits error codes into /var/log/messages

Expected Results:  no such codes

Additional info:

Comment 1 Dave Jones 2003-08-14 18:58:26 UTC
Merged, will be in the next kernel update.



Note You need to log in before you can comment on or make changes to this bug.