Bug 1015348 - adding a check to oo-diagnostics to check abrt version
adding a check to oo-diagnostics to check abrt version
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-03 22:01 EDT by August Simonelli
Modified: 2017-03-08 12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-21 15:45:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description August Simonelli 2013-10-03 22:01:21 EDT
Description of problem:

An OSE install which includes the python cart requires a very specific version of the abrt package or the entire cartridge is unusable (due to https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=976874)

Version-Release number of selected component (if applicable):

OSE 1.2.1

How reproducible:

Install OSE 1.2.1 python carts with <= abrt-2.0.8-15.el6.x86_64 available. 

Steps to Reproduce:
1. Standard OSE installation steps.
2.
3.

Actual results:

A version of abrt installs that has bugs when setting up pythin virtenvs.

Expected results:

Python carts work OOTB. :-)

Additional info:

This is more a request to have oo-diagnostics check versions of packages are correct than a bug with OSE and/or abrt :-)
Comment 1 August Simonelli 2013-10-03 22:02:25 EDT
I should have added the minimum abrt packages are

abrt-2.0.8-16.el6_4.1.x86_64

:-)
Comment 3 Luke Meyer 2013-10-07 11:36:08 EDT
I'm a little confused. Is the actual abrt package a problem? Or just abrt-addon-python as reported in bug 907449 ?

oo-diagnostics already reports if abrt-addon-python is present (when run on a node).

https://github.com/openshift/enterprise-server/blob/enterprise-1.2.z/common/bin/oo-diagnostics#L1178-L1190

(In fact, that should probably be scoped to the non-working versions of abrt-addon-python once we release a working version.)

The openshift-extras install script also gets rid of abrt-addon-python if found.

So is this something new?
Comment 4 Brenton Leanhardt 2013-10-07 11:43:27 EDT
This isn't anything new.  I forgot that we already had the check.  This bug could be updated to simply update oo-diagnostics to only check for the broken version of abrt-addon-python.
Comment 6 August Simonelli 2016-04-04 07:56:29 EDT
Yes this bug is no longer valid.

Note You need to log in before you can comment on or make changes to this bug.