Bug 1015395 - gluster volume status all --xml output doesn't have parameters of tasks
gluster volume status all --xml output doesn't have parameters of tasks
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Kaushal
SATHEESARAN
: ZStream
Depends On: 916577
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 02:22 EDT by Bala.FA
Modified: 2015-11-22 21:58 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.44.1u2rhs
Doc Type: Bug Fix
Doc Text:
Previously, the XML output of the volume status command showed only the type and task-id for replace-brick and remove-brick tasks. Bricks involved in specific tasks could not be easily identified. With this fix, a new element <param> is introduced as a child of <task>, in the XML output for volume status. The <param> tag contains the child elements <srcBrick> & <dstBrick> or <brick> to identify the bricks involved in a task.
Story Points: ---
Clone Of: 916577
Environment:
Last Closed: 2014-02-25 02:50:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bala.FA 2013-10-04 02:22:17 EDT
+++ This bug was initially created as a clone of Bug #916577 +++

Currently 'gluster volume status all --xml' output doesn't have brick parameters.

We are expecting
1. replace-brick task containing sourceBrick and destBrick
2. remove-brick task containing removal brick(s)

These parameters are needed to get actual task progress by running 'gluster volume remove-brick/replace-brick status'

--- Additional comment from Anand Avati on 2013-09-04 03:15:26 EDT ---

REVIEW: http://review.gluster.org/5771 (cli,glusterd: Task parameters in xml output) posted (#1) for review on master by Kaushal M (kaushal@redhat.com)

--- Additional comment from Anand Avati on 2013-09-05 01:52:40 EDT ---

REVIEW: http://review.gluster.org/5771 (cli,glusterd: Task parameters in xml output) posted (#2) for review on master by Kaushal M (kaushal@redhat.com)

--- Additional comment from Anand Avati on 2013-09-12 01:01:31 EDT ---

REVIEW: http://review.gluster.org/5771 (cli,glusterd: Task parameters in xml output) posted (#3) for review on master by Kaushal M (kaushal@redhat.com)

--- Additional comment from Anand Avati on 2013-09-13 01:00:01 EDT ---

REVIEW: http://review.gluster.org/5771 (cli,glusterd: Task parameters in xml output) posted (#4) for review on master by Kaushal M (kaushal@redhat.com)

--- Additional comment from Anand Avati on 2013-09-13 06:37:23 EDT ---

REVIEW: http://review.gluster.org/5771 (cli,glusterd: Task parameters in xml output) posted (#5) for review on master by Kaushal M (kaushal@redhat.com)

--- Additional comment from Anand Avati on 2013-09-13 06:38:49 EDT ---

COMMIT: http://review.gluster.org/5771 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 91cd0eae2cc1d96cbafa6457835f146503355238
Author: Kaushal M <kaushal@redhat.com>
Date:   Wed Sep 4 11:50:40 2013 +0530

    cli,glusterd: Task parameters in xml output
    
    This patch introduces task parameters for the asynchronus task shown in
    volume status. The parameters are only given for xml output. The
    parameters shown currently are,
    - source and destination bricks for replace-brick tasks
      ......
            <tasks>
              <task>
                <type>Replace brick</type>
                <id>3d1a1005-9d2e-4ae0-bd62-577bc1d333a3</id>
                <status>1</status>
                <params>
                  <srcBrick>archm:/export/test4</srcBrick>
                  <dstBrick>archm:/export/test-replace1</dstBrick>
                </params>
              </task>
            </tasks>
      ......
    - list of bricks being removed for remove-brick tasks
      ......
            <tasks>
              <task>
                <type>Remove brick</type>
                <id>901c20ca-0da2-41de-8669-5f0caca6b846</id>
                <status>1</status>
                <params>
                  <brick>archm:/export/test2</brick>
                  <brick>archm:/export/test3</brick>
                </params>
              </task>
            </tasks>
      ......
    
    The changes for non-xml output will be done in a subsequent patch.
    
    Change-Id: I322afe2f83ed8adeddb99f7962c25911204dc204
    BUG: 916577
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/5771
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Vijay Bellur <vbellur@redhat.com>

--- Additional comment from Anand Avati on 2013-09-19 06:45:33 EDT ---

REVIEW: http://review.gluster.org/5973 (cli,glusterd: Task parameters in xml output) posted (#1) for review on release-3.4 by Kaushal M (kaushal@redhat.com)

--- Additional comment from Anand Avati on 2013-09-19 17:09:31 EDT ---

COMMIT: http://review.gluster.org/5973 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 999c177ffba9b940d977901ede3aaf55c236e255
Author: Kaushal M <kaushal@redhat.com>
Date:   Wed Sep 4 11:50:40 2013 +0530

    cli,glusterd: Task parameters in xml output
    
     Backport of 91cd0eae2cc1d96cbafa6457835f146503355238 from master
    
    This patch introduces task parameters for the asynchronus task shown in
    volume status. The parameters are only given for xml output. The
    parameters shown currently are,
    - source and destination bricks for replace-brick tasks
      ......
            <tasks>
              <task>
                <type>Replace brick</type>
                <id>3d1a1005-9d2e-4ae0-bd62-577bc1d333a3</id>
                <status>1</status>
                <params>
                  <srcBrick>archm:/export/test4</srcBrick>
                  <dstBrick>archm:/export/test-replace1</dstBrick>
                </params>
              </task>
            </tasks>
      ......
    - list of bricks being removed for remove-brick tasks
      ......
            <tasks>
              <task>
                <type>Remove brick</type>
                <id>901c20ca-0da2-41de-8669-5f0caca6b846</id>
                <status>1</status>
                <params>
                  <brick>archm:/export/test2</brick>
                  <brick>archm:/export/test3</brick>
                </params>
              </task>
            </tasks>
      ......
    
    The changes for non-xml output will be done in a subsequent patch.
    
    BUG: 916577
    Change-Id: Iade8a4974aefc5ffb080553496ae5a3169055090
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/5973
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 2 Amar Tumballi 2013-10-04 05:00:34 EDT
https://code.engineering.redhat.com/gerrit/#/c/13664
Comment 3 SATHEESARAN 2013-12-20 08:56:43 EST
Verified with glusterfs-3.4.0.51rhs.el6rhs

Replace bricks has source and destination brick as follows :

<task>
            <type>Replace brick</type>
            <id>e3c296c7-1081-4261-92ed-cfcfebe90e93</id>
            <status>1</status>
            <statusStr>completed</statusStr>
            <params>
              <srcBrick>10.70.37.198:/rhs/brick1/ff1</srcBrick>
              <dstBrick>10.70.37.198:/rhs/brick2/ff1</dstBrick>
            </params>
</task>

Remove-brick operation showed up bricks that are removed in "gluster volume status all --xml"
<tasks>
          <task>
            <type>Remove brick</type>
            <id>4d714504-228d-40e6-ad37-20770b629a74</id>
            <status>1</status>
            <statusStr>in progress</statusStr>
            <params>
              <brick>10.70.37.198:/rhs/brick2/ff1</brick>
            </params>
          </task>
</tasks>
Comment 4 Pavithra 2014-01-16 01:08:58 EST
Kaushal,

Can you please verify the doc text for technical accuracy?
Comment 5 Kaushal 2014-01-16 06:01:50 EST
Doc text looks fine.
Comment 7 errata-xmlrpc 2014-02-25 02:50:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.