Bug 1015400 - CLI module command doesn't allow cross platform resource paths
CLI module command doesn't allow cross platform resource paths
Status: CLOSED WONTFIX
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: CLI (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: EAP 6.4.2
Assigned To: Ivo Studensky
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 02:39 EDT by Ivo Studensky
Modified: 2015-06-15 09:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-15 09:47:42 EDT
Type: Feature Request
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-1871 Major Resolved CLI module command doesn't allow cross platform resource paths 2015-06-16 09:28:28 EDT

  None (edit)
Description Ivo Studensky 2013-10-04 02:39:07 EDT
Description of problem:
Backport of WFLY-1871 to EAP.

Original description:
The CLI module command has an argument called "resources". This argument allows you to specify one or more resources separated by the platform-specific path separator. The problem with this is that you can not create a platform-independent script that uses this resources argument.

I have not found a universal path separator character that would work. However, since the creator of the script knows the characters used in his path, we can allow him to specify his own separator.

As an enhancement, I propose to add an argument called "resourceDelimiter". If present, the ASModuleHandler class will use the user-defined delimiter instead of the platform-specific path separator character.

Example usage:

module add --name=org.foo --resources=firstResource.jar:secondResource.jar --resourceDelimiter=: --module-xml=foo-module.xml

The above command would work on Unix, Windows, or any other platform.
Comment 1 Alexey Loubyansky 2013-10-04 10:47:09 EDT
ok, just, please, follow the argument naming convention, i.e. --resource-delimiter
Comment 3 Ivo Studensky 2013-10-04 11:09:00 EDT
Changed to Enhancement.
Comment 4 JBoss JIRA Server 2013-10-04 11:38:20 EDT
Stan Silvert <ssilvert@jboss.com> updated the status of jira WFLY-1871 to Reopened
Comment 5 JBoss JIRA Server 2013-10-04 11:38:20 EDT
Stan Silvert <ssilvert@jboss.com> made a comment on jira WFLY-1871

Reopening.  The naming convention issue on the resource delimiter was missed the first time around.
Comment 8 JBoss JIRA Server 2013-12-23 09:43:01 EST
Stan Silvert <ssilvert@jboss.com> updated the status of jira WFLY-1871 to Resolved
Comment 10 Carlo de Wolf 2015-06-15 09:47:42 EDT
Triage, no RFE in 6.4.z

Note You need to log in before you can comment on or make changes to this bug.