Bug 1015401 - HP scanners are not recognized by sane by default
HP scanners are not recognized by sane by default
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 02:44 EDT by Mansour Behabadi
Modified: 2013-10-28 07:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-28 07:12:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mansour Behabadi 2013-10-04 02:44:33 EDT
Description of problem:

After installing sane and sane-backends-drivers-scanners, my HP scanner was still not picked up by `scanimage -L`


Version-Release number of selected component (if applicable): 1.0.23-18


How reproducible: always


Steps to Reproduce:
1. Install `sane` and `sane-backends-drivers-scanners`
2. Turn your HP scanner on (mine is a Deskjet 2200)
2. Execute `scanimage -L` in a shell

Actual results: No scanners found


Expected results: Your scanner should show with its path


Additional info:
Comment 1 Mansour Behabadi 2013-10-04 02:46:03 EDT
The issue is that sane-backends relies on libsane-hpaio to recognize and operate HP scanners. Therefore, sane-backends should have libsane-hpaio as its dependency. HP scanners are the only ones that have their own driver package.
Comment 2 Mansour Behabadi 2013-10-04 03:01:55 EDT
The issue is caused by bug 430834 and despite the issue, it has stayed the same. As Joseph puts it, making the hardware work should be utmost priority. I'm not knowledgeable enough to offer an alternative but I had to spend a good half hour to figure this out. If I had to spend half an hour per device, it would take a week to install my linux.
Comment 3 Nils Philippsen 2013-10-28 07:12:13 EDT
The issue is that I can't let sane-backends simply require the drivers packages: as color management now needs sane-backends libraries, this would pull in the drivers always except in the most stripped down configurations. This would make live media explode space-wise.

I'm working on letting udev, PackageKit install the necessary drivers if the hardware is detected. See bug #844514.

Note You need to log in before you can comment on or make changes to this bug.