Bug 1015426 - Missing Header gtklistbox.h
Missing Header gtklistbox.h
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 04:27 EDT by Florian "der-flo" Lehner
Modified: 2013-10-04 07:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-04 07:36:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian "der-flo" Lehner 2013-10-04 04:27:25 EDT
Description of problem:

/usr/include/gtk-3.0/gtk/gtklistbox.h is missing


Version-Release number of selected component (if applicable):

Installed Packages
Name        : gtk+-devel
Arch        : x86_64
Epoch       : 1
Version     : 1.2.10
Release     : 73.fc18

How reproducible:

Source doesn't compile, if GtkListBox is used and all gtk-Headers are included.

Steps to Reproduce:
1. install gtk+-devel
2. get some source using GtkListBox
3. try to compile

Actual results:

Source doesn't compile

Expected results:

Source does compile

Additional info:
Comment 1 Paul Howarth 2013-10-04 04:45:45 EDT
This is a gtk3 issue, not a gtk1 issue. The package you'd want would be gtk3-devel but that header file doesn't seem to be there either, possibly because I think GtkListBox was introduced in Gtk 3.10, and F-18 has Gtk 3.6.
Comment 2 Florian "der-flo" Lehner 2013-10-04 07:36:34 EDT
You are right!
It's my fault. I didnt's see, that GtkListBox was introduced in Gtk 3.10.

So I close this bug, because it isn't one.

Note You need to log in before you can comment on or make changes to this bug.