Bug 101548 - Kicker crahes when right click on KDE Panel --> remove --> buttons
Summary: Kicker crahes when right click on KDE Panel --> remove --> buttons
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-03 15:21 UTC by Dan Nolast
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-05 15:16:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Nolast 2003-08-03 15:21:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030716

Description of problem:
when you right click on the KDE Panel (kicker) and go to remove, then buttons,
just as the buttons menu is supposed to come up, kicker crashes  and causes
signal 11. Found this out because there is whitespace that acts like a button is
there (other buttons must snap around them when moving and so forth but
left-clicking them does nothing). I did manage to get this error message in the
konsole: 
"
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/PlainClock) Negative sizes (53,-4) are not
possible
QWidget::setMinimumSize: The smallest allowed size is (0,0)
QWidget::setMaximumSize: (unnamed/PlainClock) Negative sizes (53,-4) are not
possible
"
However resizing my KDE Panel is to no avail, resulting in the same error message.

I was able to get that error message because when I first discovered this I was
lucky enough to have a konsole running and simply went to /usr/bin and started
kicker back up from that konsole because after some recreation kicker only
started back up automatically some of the time.


Version-Release number of selected component (if applicable):
kdebase-3.0.5a-4

How reproducible:
Always

Steps to Reproduce:
1.right click on the KDE Panel
2.Move mouse over "Remove"
3.Move mouse over "Button"
4.Crash city
    

Actual Results:  Sometimes kicker would restart of its own accord, other times I
would have to do this: "./usr/bin/kicker" to get the KDE Panel back.

Expected Results:  I was trying to remove the invisible "buttons" that take up
space on the Panel.

Additional info:

Comment 1 Ngo Than 2003-08-05 15:16:13 UTC
Hm, it seems that your kickerrc is broken. Please delete or move 
$HOME/.kde/share/config/kickerrc and restart KDE again.


Note You need to log in before you can comment on or make changes to this bug.