Bug 1015501 - JMS Queue/Topic configuration change is not persistent after restart
JMS Queue/Topic configuration change is not persistent after restart
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: Plugin -- JBoss EAP 5 (Show other bugs)
JON 3.2
x86_64 Linux
unspecified Severity medium
: ER02
: JON 3.3.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 08:05 EDT by Libor Fuka
Modified: 2014-12-11 09:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-11 09:02:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Fuka 2013-10-04 08:05:05 EDT
Description of problem:
1. Create your JMS Queue/Topic
2. change configuration - for example set Max Delivery Attempts to 5
3. restart EAP5 from JON UI
4. Max Delivery Attempts config of your created JMS Queue/Topic is set to default -1

Version-Release number of selected component (if applicable):
JON 3.2.0.ER2 + EAP 5.2.0.GA


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Max Delivery Attempts set to 5

Additional info:
Comment 1 Radim Hatlapatka 2013-10-17 06:44:44 EDT
In EAP 5 server log is printed this exception:

2013-10-17 06:33:06,299 WARN  [org.jboss.system.server.profileservice.persistence.deployer.ProfileServicePersistenceDeployer] (main) Failed to update the persisted attachment information
java.lang.ClassCastException: org.jboss.system.server.profileservice.persistence.xml.PersistedSimpleValue cannot be cast to org.jboss.system.server.profileservice.persistence.xml.PersistedCompositeValue
        at org.jboss.system.server.profileservice.persistence.AbstractValueRecreation.createMetaValue(AbstractValueRecreation.java:187)
        at org.jboss.system.server.profileservice.persistence.AbstractValueRecreation.handleMapCompositeMetaType(AbstractValueRecreation.java:313)
        at org.jboss.system.server.profileservice.persistence.AbstractValueRecreation.createCompositeValue(AbstractValueRecreation.java:278)
        at org.jboss.system.server.profileservice.persistence.AbstractValueRecreation.createMetaValue(AbstractValueRecreation.java:187)
        at org.jboss.system.server.profileservice.persistence.AbstractValueRecreation.handleMapCompositeMetaType(AbstractValueRecreation.java:313)
        at org.jboss.system.server.profileservice.persistence.AbstractValueRecreation.createCompositeValue(AbstractValueRecreation.java:278)
        at org.jboss.system.server.profileservice.persistence.AbstractValueRecreation.createMetaValue(AbstractValueRecreation.java:187)
        at org.jboss.system.server.profileservice.persistence.AbstractManagedObjectRecreation.createValue(AbstractManagedObjectRecreation.java:176)
        at org.jboss.system.server.profileservice.persistence.AbstractManagedObjectRecreation.processManagedProperty(AbstractManagedObjectRecreation.java:157)
        at org.jboss.system.server.profileservice.persistence.AbstractManagedObjectRecreation.processManagedProperty(AbstractManagedObjectRecreation.java:130)
        at org.jboss.system.server.profileservice.persistence.AbstractManagedObjectRecreation.processManagedProperty(AbstractManagedObjectRecreation.java:105)
        at org.jboss.system.server.profileservice.persistence.AbstractManagedObjectRecreation.processProperties(AbstractManagedObjectRecreation.java:84)
        at org.jboss.system.server.profileservice.persistence.DefaultRecreationDelegate.updateManagedObject(DefaultRecreationDelegate.java:73)
        at org.jboss.system.server.profileservice.persistence.DefaultManagedObjectPersistencePlugin.updateManagedObject(DefaultManagedObjectPersistencePlugin.java:82)
        at org.jboss.system.server.profileservice.persistence.DelegatingPersistencePlugin.updateManagedObject(DelegatingPersistencePlugin.java:151)
        at org.jboss.system.server.profileservice.persistence.component.AbstractComponentMapper.updateComponent(AbstractComponentMapper.java:164)
        at org.jboss.system.server.profileservice.persistence.component.AbstractComponentMapper.restoreComponent(AbstractComponentMapper.java:83)
        at org.jboss.system.server.profileservice.persistence.AbstractPersistenceFactory.restorePersistenceRoot(AbstractPersistenceFactory.java:100)
        at org.jboss.system.server.profileservice.persistence.deployer.ProfileServicePersistenceDeployer.applyPersistentChanges(ProfileServicePersistenceDeployer.java:128)
        at org.jboss.system.server.profileservice.persistence.deployer.ProfileServicePersistenceDeployer.internalDeploy(ProfileServicePersistenceDeployer.java:93)
        at org.jboss.deployers.spi.deployer.helpers.AbstractRealDeployer.deploy(AbstractRealDeployer.java:55)
        at org.jboss.deployers.plugins.deployers.DeployerWrapper.deploy(DeployerWrapper.java:179)
        at org.jboss.deployers.plugins.deployers.DeployersImpl.doDeploy(DeployersImpl.java:1454)
        at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentFirst(DeployersImpl.java:1172)
        at org.jboss.deployers.plugins.deployers.DeployersImpl.install(DeployersImpl.java:1113)
        at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
        at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1652)
        at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:938)
        at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1082)
        at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:988)
        at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:826)
        at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:556)
        at org.jboss.deployers.plugins.deployers.DeployersImpl.process(DeployersImpl.java:789)
        at org.jboss.deployers.plugins.main.MainDeployerImpl.process(MainDeployerImpl.java:699)
        at org.jboss.system.server.profileservice.repository.MainDeployerAdapter.process(MainDeployerAdapter.java:117)
        at org.jboss.system.server.profileservice.repository.ProfileDeployAction.install(ProfileDeployAction.java:70)
        at org.jboss.system.server.profileservice.repository.AbstractProfileAction.install(AbstractProfileAction.java:53)
        at org.jboss.system.server.profileservice.repository.AbstractProfileService.install(AbstractProfileService.java:403)
        at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
        at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1652)
        at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:938)
        at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1082)
        at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:988)
        at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:778)
        at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:543)
        at org.jboss.system.server.profileservice.repository.AbstractProfileService.registerProfile(AbstractProfileService.java:308)
        at org.jboss.system.server.profileservice.ProfileServiceBootstrap.start(ProfileServiceBootstrap.java:256)
        at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:461)
        at org.jboss.Main.boot(Main.java:229)
        at org.jboss.Main$1.call(Main.java:561)
        at org.jboss.Main$1.call(Main.java:557)
        at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
        at java.util.concurrent.FutureTask.run(FutureTask.java:138)
        at java.lang.Thread.run(Thread.java:662)
Comment 2 Radim Hatlapatka 2013-10-17 06:58:03 EDT
The exception stacktrace makes it clear that the issue is in Class which provides the updated information. The question is on which side it should be corrected EAP 5 or JON EAP5 plugin. As it was working with JON 3.1.2 this is regression on JON EAP5 plugin side and should be fixed there.
Comment 3 Simeon Pinder 2013-11-08 09:41:33 EST
Moving to unspecified target milestone as only JON 3.2.0 'blockers'(https://url.corp.redhat.com/bz-jon32-blockers-list-notmodified-nodocs) will make it into subsequent builds after ER5.
Comment 6 Jay Shaughnessy 2014-09-04 14:09:32 EDT
This did not reproduce for me against JON3.3 ER and EAP 5.2 (default config). Asking whether this can be closed, or for more detailed reproduction steps.  I updated the DLQ queue, updating Max Delivery Attempts to 5.  Note that I did need to set a value for the ExpiryQueue resource config field to get an update to work.
Comment 7 Radim Hatlapatka 2014-09-15 10:07:05 EDT
I have verified with JON 3.3.0.ER2 that now the configuration is properly updated.

Note You need to log in before you can comment on or make changes to this bug.