Bug 1015551 - Change IP Toolchain Inheritance
Change IP Toolchain Inheritance
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Build Process (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER7
: 6.0.0
Assigned To: Nick Cross
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 09:36 EDT by Nick Cross
Modified: 2015-08-02 19:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Cross 2013-10-04 09:36:24 EDT
ip-parent (the IP toolchain) currently inherits jboss-parent-10-redhat-2. The problem with this is that due to the vman injection all of the quickstarts will use this toolchain. The quickstarts will then require the maven -redhat monolith plugins to be in the maven wolf repository that is distributed.

A solution might be to inherit jboss-parent-10 and use community plugins instead.
Comment 2 Nick Cross 2013-12-17 09:32:44 EST
Completed for ER7
Comment 3 Jiri Sedlacek 2013-12-18 08:47:25 EST
verified in ER7-2 repo

Note You need to log in before you can comment on or make changes to this bug.