Bug 1015596 - autogenerated test jar dependencies aren't satisfiable
autogenerated test jar dependencies aren't satisfiable
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xmvn (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
: Upstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 10:55 EDT by Robert Rati
Modified: 2013-10-10 10:52 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.1.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 10:52:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2013-10-04 10:55:12 EDT
Description of problem:
autogenerated dependencies for test jars seem to be created in to form:
mvn(org.apache.hadoop:hadoop-yarn-server-tests:test-jar:)

But the rpm with the test jars have provides like:
mvn(org.apache.hadoop:hadoop-yarn-server-tests) = 2.0.5-alpha
mvn(org.apache.hadoop:hadoop-yarn-server-tests::tests:) = 2.0.5-alpha

The result is the rpm, which has poms with test-jar dependencies, results in failed dependencies even though the dependencies are actually provided by the packaging saying it is lacking the dependency.  An example rpm with this problem:

http://koji.fedoraproject.org/koji/rpminfo?rpmID=4457348

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Mikolaj Izdebski 2013-10-07 05:47:21 EDT
I am unable to reproduce this.
Please attach a simple reproducer.
Comment 2 Mikolaj Izdebski 2013-10-07 07:38:33 EDT
I think I know where the bug is.
Comment 3 Mikolaj Izdebski 2013-10-07 14:20:46 EDT
Fixed in xmvn-1.1.0-2
Comment 4 Mikolaj Izdebski 2013-10-10 10:52:16 EDT
I believe that this bug is fixed in xmvn-1.1.0-2,
which is available in Fedora 20, so I am closing this bug now.

The build containing the fix can be found at Koji:
http://koji.fedoraproject.org/koji/buildinfo?buildID=469812

Note You need to log in before you can comment on or make changes to this bug.