Bug 1015604 - scroll wheel doesn't scroll gtk treeview on kde since gtk3 3.8
scroll wheel doesn't scroll gtk treeview on kde since gtk3 3.8
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
20
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 11:05 EDT by Jan Safranek
Modified: 2014-11-03 10:21 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-03 10:21:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager --debug output (6.28 KB, text/plain)
2013-10-07 03:33 EDT, Jan Safranek
no flags Details

  None (edit)
Description Jan Safranek 2013-10-04 11:05:46 EDT
The list list of virtual machines does not react to mouse wheel. This may sound like stupid issue, but it's quite annoying usability bug for me. 

Version-Release number of selected component (if applicable):
virt-manager-0.10.0-3.fc19.noarch

How reproducible:
always

Steps to Reproduce:
1. run virt-manager
2. use mouse scroll on the main window with list of virtual machines

Actual results:
the list does not scroll

Expected results:
the list scrolls up&down
Comment 1 Cole Robinson 2013-10-04 11:45:38 EDT
Hmm, I can't reproduce on F19 VM with spice, but interraction is really weird over ssh -X, though I don't have any clue what we could be doing to cause issues there.

Are you using ssh -X, some non-gnome desktop env, etc? Any errors in virt-manager --debug when reproducing?
Comment 2 Jan Safranek 2013-10-07 03:33:59 EDT
Created attachment 808740 [details]
virt-manager --debug output

There is no error in libvirt output. I use KDE 4.11 as distributed in Fedora, no ssh -X.
Comment 3 Jan Safranek 2013-10-07 04:44:52 EDT
I also checked that mouse scroll works well in Gnome on the same machine.

There may be something wrong in KDE or GTK or who knows what.
Comment 4 Cole Robinson 2013-10-07 09:49:12 EDT
Sounds like:

https://bugs.kde.org/show_bug.cgi?id=321284
https://bugzilla.gnome.org/show_bug.cgi?id=708570

Which says it is a gtk3 issue introduced in 3.8+

I confirmed it affects F20 as well, reassigning there since it might help it get more attention.
Comment 5 Sergio Monteiro Basto 2014-11-03 10:07:06 EST
this is fixed some time ago .

Note You need to log in before you can comment on or make changes to this bug.