Bug 1015620 - UnicodeDecodeError in text mode with lang=de_DE.UTF-8
UnicodeDecodeError in text mode with lang=de_DE.UTF-8
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Shea
Fedora Extras Quality Assurance
abrt_hash:f7c1074965f82e774fed487fb5c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 11:55 EDT by Felix Kaechele
Modified: 2014-01-30 17:12 EST (History)
8 users (show)

See Also:
Fixed In Version: anaconda-20.23-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-30 17:12:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (164.27 KB, text/plain)
2013-10-04 11:55 EDT, Felix Kaechele
no flags Details
File: anaconda.log (6.16 KB, text/plain)
2013-10-04 11:55 EDT, Felix Kaechele
no flags Details
File: environ (394 bytes, text/plain)
2013-10-04 11:55 EDT, Felix Kaechele
no flags Details
File: ks.cfg (883 bytes, text/plain)
2013-10-04 11:55 EDT, Felix Kaechele
no flags Details
File: lsblk_output (1.04 KB, text/plain)
2013-10-04 11:55 EDT, Felix Kaechele
no flags Details
File: nmcli_dev_list (5.92 KB, text/plain)
2013-10-04 11:55 EDT, Felix Kaechele
no flags Details
File: os_info (291 bytes, text/plain)
2013-10-04 11:55 EDT, Felix Kaechele
no flags Details
File: program.log (18.98 KB, text/plain)
2013-10-04 11:55 EDT, Felix Kaechele
no flags Details
File: storage.log (51.74 KB, text/plain)
2013-10-04 11:55 EDT, Felix Kaechele
no flags Details
File: syslog (60.18 KB, text/plain)
2013-10-04 11:55 EDT, Felix Kaechele
no flags Details
File: ifcfg.log (459 bytes, text/plain)
2013-10-04 11:56 EDT, Felix Kaechele
no flags Details
File: packaging.log (13.81 KB, text/plain)
2013-10-04 11:56 EDT, Felix Kaechele
no flags Details

  None (edit)
Description Felix Kaechele 2013-10-04 11:55:15 EDT
Description of problem:
Installing F20 from PXE with a Kickstart

Version-Release number of selected component:
anaconda-20.21-1

The following was filed automatically by anaconda:
anaconda 20.21-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 647, in <genexpr>
    return u"\n".join(u"".join(l) for l in self._buffer)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 647, in __unicode__
    return u"\n".join(u"".join(l) for l in self._buffer)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 550, in show_all
    print unicode(w)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 286, in _do_redraw
    screen.window.show_all()
UnicodeDecodeError: 'utf8' codec can't decode byte 0xc3 in position 0: unexpected end of data

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   BOOTIF=01-52:54:00:43:67:72 inst.ks=http://felix.fetzig.org/install/minimal.ks inst.text inst.headless inst.repo=http://mirror.netcologne.de/fedora/linux/development/20/x86_64/os/
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.2-301.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20

Potential duplicate: bug 965556
Comment 1 Felix Kaechele 2013-10-04 11:55:20 EDT
Created attachment 807749 [details]
File: anaconda-tb
Comment 2 Felix Kaechele 2013-10-04 11:55:24 EDT
Created attachment 807750 [details]
File: anaconda.log
Comment 3 Felix Kaechele 2013-10-04 11:55:28 EDT
Created attachment 807751 [details]
File: environ
Comment 4 Felix Kaechele 2013-10-04 11:55:32 EDT
Created attachment 807752 [details]
File: ks.cfg
Comment 5 Felix Kaechele 2013-10-04 11:55:36 EDT
Created attachment 807753 [details]
File: lsblk_output
Comment 6 Felix Kaechele 2013-10-04 11:55:41 EDT
Created attachment 807754 [details]
File: nmcli_dev_list
Comment 7 Felix Kaechele 2013-10-04 11:55:45 EDT
Created attachment 807755 [details]
File: os_info
Comment 8 Felix Kaechele 2013-10-04 11:55:49 EDT
Created attachment 807756 [details]
File: program.log
Comment 9 Felix Kaechele 2013-10-04 11:55:53 EDT
Created attachment 807757 [details]
File: storage.log
Comment 10 Felix Kaechele 2013-10-04 11:55:57 EDT
Created attachment 807758 [details]
File: syslog
Comment 11 Felix Kaechele 2013-10-04 11:56:01 EDT
Created attachment 807759 [details]
File: ifcfg.log
Comment 12 Felix Kaechele 2013-10-04 11:56:06 EDT
Created attachment 807760 [details]
File: packaging.log
Comment 13 Felix Kaechele 2013-10-04 12:06:27 EDT
Looks like an issue with text-mode/headless installations. When removing inst.text and inst.headless from the cmdline arguments of the kernel the installation works.
Comment 14 David Shea 2013-10-04 13:56:35 EDT
This is happening while processing the spoke statuses. The installation source is displaying "Custom software selected" (translated to "Benutzerdefinierte Software ausgewählt"), and something is tripping up over the utf-8 characters.
Comment 15 Fedora Update System 2013-10-08 19:37:44 EDT
anaconda-20.23-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/anaconda-20.23-1.fc20
Comment 16 Fedora Update System 2013-10-10 10:39:00 EDT
Package pykickstart-1.99.42-1.fc20, anaconda-20.23-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pykickstart-1.99.42-1.fc20 anaconda-20.23-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18714/pykickstart-1.99.42-1.fc20,anaconda-20.23-1.fc20
then log in and leave karma (feedback).

Note You need to log in before you can comment on or make changes to this bug.