Bug 1015650 - [abrt] yumex-3.0.12-1.fc19: backend-launcher.py:36:dispatcher:AttributeError: 'exceptions.IOError' object has no attribute 'msg'
[abrt] yumex-3.0.12-1.fc19: backend-launcher.py:36:dispatcher:AttributeError:...
Status: CLOSED DUPLICATE of bug 1012508
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
abrt_hash:0fa46c957bdbe9b846d946054c4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 13:21 EDT by ARIKO
Modified: 2013-10-13 01:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 06:19:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (490 bytes, text/plain)
2013-10-04 13:21 EDT, ARIKO
no flags Details
File: environ (269 bytes, text/plain)
2013-10-04 13:21 EDT, ARIKO
no flags Details

  None (edit)
Description ARIKO 2013-10-04 13:21:07 EDT
Version-Release number of selected component:
yumex-3.0.12-1.fc19

Additional info:
reporter:       libreport-2.1.7
cmdline:        /usr/bin/python -E /usr/share/yumex/backend-launcher.py
executable:     /usr/share/yumex/backend-launcher.py
kernel:         3.11.2-201.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
backend-launcher.py:36:dispatcher:AttributeError: 'exceptions.IOError' object has no attribute 'msg'

Traceback (most recent call last):
  File "/usr/share/yumex/backend-launcher.py", line 60, in <module>
    rc = dispatcher()
  File "/usr/share/yumex/backend-launcher.py", line 36, in dispatcher
    print ":error\texception : %s %s " % ("", e.msg)
AttributeError: 'exceptions.IOError' object has no attribute 'msg'

Local variables in innermost frame:
e: IOError(5, 'Input/output error')
Comment 1 ARIKO 2013-10-04 13:21:11 EDT
Created attachment 807886 [details]
File: backtrace
Comment 2 ARIKO 2013-10-04 13:21:14 EDT
Created attachment 807887 [details]
File: environ
Comment 3 Tim Lauridsen 2013-10-06 06:19:48 EDT

*** This bug has been marked as a duplicate of bug 1012508 ***
Comment 4 D. Charles Pyle 2013-10-13 01:37:10 EDT
Happened while trying to reinstall a kernel.  Selected kernel in list, installation failed saying a package was not there when it actually was there in the list.  Then it crashed and threw the error that brought me here.  Since I am not authorized to post in the bug report that still is open for this problem, I post it here since abrt directed me here.

There is a lot of other strangeness going on with this release.  Many times packages are listed as being there but trying to install them results in multiple empty transactions and rpm database corruptions.

Note You need to log in before you can comment on or make changes to this bug.