Bug 101567 - kernel BUG at swapfile.c:264
kernel BUG at swapfile.c:264
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-03 22:08 EDT by Bojan Smojver
Modified: 2007-04-18 12:56 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-23 23:14:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2003-08-03 22:08:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030530 Galeon/1.3.7

Description of problem:
The machine is ALR Revolution Quad 6, 4 x Pentium Pro 200 MHz, 256 MB ECC EDO
RAM, 2 x Mylex DAC960 RAID controllers, multiple Digial RAID boxes, DLT tape
drive (DEC TZ88), 2 x DAT tape (Sony SDT-5000), 2 x Intel EtherExpress PRO 100B
(bonding configuration), 2 x Symbios logic SCSI controller (8-bit).

I was running a backup (tar) on this machine to the DLT tape drive when this
error occured.

This is what I found in /var/log/messages of this system:

==================================================================
Aug  4 00:29:55 meowth kernel: ------------[ cut here ]------------
Aug  4 00:29:55 meowth kernel: kernel BUG at swapfile.c:264!
Aug  4 00:29:55 meowth kernel: invalid operand: 0000
Aug  4 00:29:55 meowth kernel: parport_pc lp parport nfsd lockd sunrpc autofs
e100 bonding st ext3 jbd DAC960 ncr53c8xx sd_mo
d scsi_mod  
Aug  4 00:29:55 meowth kernel: CPU:    0
Aug  4 00:29:55 meowth kernel: EIP:    0060:[<c014a9d5>]    Not tainted
Aug  4 00:29:55 meowth kernel: EFLAGS: 00010246
Aug  4 00:29:55 meowth kernel: 
Aug  4 00:29:55 meowth kernel: EIP is at can_share_swap_page [kernel] 0x15
(2.4.20-19.9smp)
Aug  4 00:29:55 meowth kernel: eax: 00000000   ebx: 00000000   ecx: c0137eed  
edx: c1000030
Aug  4 00:29:55 meowth kernel: esi: c1106e88   edi: 08347ad8   ebp: 00000001  
esp: c3e37ea0
Aug  4 00:29:55 meowth kernel: ds: 0068   es: 0068   ss: 0068
Aug  4 00:29:55 meowth kernel: Process spamd (pid: 9962, stackpage=c3e37000)
Aug  4 00:29:55 meowth kernel: Stack: c014f264 c9ba8080 c0137eed c0137eed
c1106e88 08344330 c126c2b0 c126c2b0 
Aug  4 00:29:55 meowth kernel:        cf635500 c9ba8080 c0bd3880 08347ad8
00000001 c0138f3e c0bd3880 c61c0c80 
Aug  4 00:29:55 meowth kernel:        08347ad8 caffed1c c9ba8080 04b1d025
00000000 c0bd3880 c61c0c80 08347ad8 
Aug  4 00:29:55 meowth kernel: Call Trace:   [<c014f264>] __pte_chain_free
[kernel] 0x24 (0xc3e37ea0))
Aug  4 00:29:55 meowth kernel: [<c0137eed>] do_wp_page [kernel] 0x4d (0xc3e37ea8))
Aug  4 00:29:55 meowth kernel: [<c0137eed>] do_wp_page [kernel] 0x4d (0xc3e37eac))
Aug  4 00:29:55 meowth kernel: [<c0138f3e>] handle_mm_fault [kernel] 0x11e
(0xc3e37ed4))
Aug  4 00:29:55 meowth kernel: [<c011c508>] do_page_fault [kernel] 0x188
(0xc3e37f04))
Aug  4 00:29:55 meowth kernel: [<c016080c>] __user_walk [kernel] 0x5c (0xc3e37f1c))
Aug  4 00:29:55 meowth kernel: [<c015b91f>] vfs_stat [kernel] 0x1f (0xc3e37f38))
Aug  4 00:29:55 meowth kernel: [<c0160a6e>] open_namei [kernel] 0x7e (0xc3e37f40))
Aug  4 00:29:55 meowth kernel: [<c012d8be>] update_process_times [kernel] 0x3e
(0xc3e37f84))
Aug  4 00:29:55 meowth kernel: [<c0119f6c>] smp_apic_timer_interrupt [kernel]
0x14c (0xc3e37fa0))
Aug  4 00:29:55 meowth kernel: [<c011c380>] do_page_fault [kernel] 0x0 (0xc3e37fb0))
Aug  4 00:29:55 meowth kernel: [<c01099c0>] error_code [kernel] 0x34 (0xc3e37fb8))
Aug  4 00:29:55 meowth kernel: 
Aug  4 00:29:55 meowth kernel: 
Aug  4 00:29:55 meowth kernel: Code: 0f 0b 08 01 dc 60 28 c0 8b 51 14 83 fa 02
74 3b 83 fa 02 7f 
==================================================================

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:
Comment 1 Bojan Smojver 2003-08-10 17:54:41 EDT
On the same SMP box, there seems to be other problems with 2.4.20-19.9smp
kernel. Here is what I found in the log this morning:

----------------------------------------------
Aug 10 04:06:00 meowth kernel: Unable to handle kernel paging request at virtual
 address ffffffff
Aug 10 04:06:00 meowth kernel:  printing eip:
Aug 10 04:06:00 meowth kernel: ffffffff
Aug 10 04:06:00 meowth kernel: *pde = 00003067
Aug 10 04:06:00 meowth kernel: *pte = 00000000
Aug 10 04:06:00 meowth kernel: Oops: 0000
Aug 10 04:06:00 meowth kernel: parport_pc lp parport nfsd lockd sunrpc autofs e1
00 bonding st ext3 jbd DAC960 ncr53c8xx sd_mod scsi_mod  
Aug 10 04:06:00 meowth kernel: CPU:    1
Aug 10 04:06:00 meowth kernel: EIP:    0060:[<ffffffff>]    Not tainted
Aug 10 04:06:00 meowth kernel: EFLAGS: 00010202
Aug 10 04:06:00 meowth kernel: 
Aug 10 04:06:00 meowth kernel: EIP is at __insmod_parport_pc_S.data_L3840 [parpo
rt_pc] 0x2f68c3ff (2.4.20-19.9smp)
Aug 10 04:06:00 meowth kernel: eax: 00000001   ebx: 00000000   ecx: c1246450   e
dx: c1000030
Aug 10 04:06:00 meowth kernel: esi: c1246450   edi: 08c3474c   ebp: 00000001   e
sp: ccc37ea4
Aug 10 04:06:00 meowth kernel: ds: 0068   es: 0068   ss: 0068
Aug 10 04:06:00 meowth kernel: Process spamd (pid: 10625, stackpage=ccc37000)
Aug 10 04:06:00 meowth kernel: Stack: c1b06a08 c7ee708c c0137eed c1246450 08c333
8c c10b2e50 c10b2e50 ce495180 
Aug 10 04:06:00 meowth kernel:        c7ee708c c004b380 08c3474c 00000001 c0138f
3e c004b380 c3aeca80 08c3474c 
Aug 10 04:06:00 meowth kernel:        c52d80d0 c7ee708c 0a65c025 00000000 c004b3
80 c3aeca80 08c3474c ccc36000 
Aug 10 04:06:00 meowth kernel: Call Trace:   [<c0137eed>] do_wp_page [kernel] 0x
4d (0xccc37eac))
Aug 10 04:06:00 meowth kernel: [<c0138f3e>] handle_mm_fault [kernel] 0x11e (0xcc
c37ed4))
Aug 10 04:06:00 meowth kernel: [<c011c508>] do_page_fault [kernel] 0x188 (0xccc3
7f04))
Aug 10 04:06:00 meowth kernel: [<c012d8be>] update_process_times [kernel] 0x3e (
0xccc37f84))
Aug 10 04:06:00 meowth kernel: [<c0119f6c>] smp_apic_timer_interrupt [kernel] 0x
14c (0xccc37fa0))
Aug 10 04:06:00 meowth kernel: [<c011c380>] do_page_fault [kernel] 0x0 (0xccc37f
b0))
Aug 10 04:06:00 meowth kernel: [<c01099c0>] error_code [kernel] 0x34 (0xccc37fb8
))
Aug 10 04:06:00 meowth kernel: 
Aug 10 04:06:00 meowth kernel: 
Aug 10 04:06:00 meowth kernel: Code:  Bad EIP value.
----------------------------------------------

The machine kind of runs after this, but if I attempt to do "ps ax", grep
through /proc or something similar, the process I started cannot be aborted. In
essence, I have to reboot the machine to make it good again.

Bojan

Note You need to log in before you can comment on or make changes to this bug.