Bug 1015679 - Org deletion fails
Org deletion fails
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Petr Chalupa
Corey Welton
: Triaged
: 1015057 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 16:12 EDT by Mike McCune
Modified: 2015-05-04 21:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 10:05:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
katello-debug (138.82 KB, application/x-gzip)
2013-10-04 16:12 EDT, Mike McCune
no flags Details

  None (edit)
Description Mike McCune 2013-10-04 16:12:55 EDT
Created attachment 807922 [details]
katello-debug

1) Create an org

2) import a manifest

3) upload some puppet content to a repo (may be unrelated)

4) Try and delete the Org 

5) Notice error:

/usr/share/katello/app/models/authorization/repository.rb:31:in `deletable?'
/usr/share/katello/app/models/repository.rb:275:in `assert_deletable'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:407:in `_run__2680243731287840431__destroy__3812871559649883762__callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:405:in `__run_callback'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:385:in `_run_destroy_callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activesupport-3.2.8/lib/active_support/callbacks.rb:81:in `run_callbacks'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/callbacks.rb:254:in `destroy'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:236:in `block in destroy'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:295:in `block in with_transaction_returning_status'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/connection_adapters/abstract/database_statements.rb:192:in `transaction'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:208:in `transaction'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:293:in `with_transaction_returning_status'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record/transactions.rb:236:in `destroy'
/usr/share/katello/app/models/glue.rb:93:in `destroy'
/opt/rh/ruby193/root/usr/share/gems/gems/activerecord-3.2.8/lib/active_record
....

attaching katello-debug
Comment 2 Walden Raines 2013-10-16 15:50:51 EDT
*** Bug 1015057 has been marked as a duplicate of this bug. ***
Comment 3 Garik Khachikyan 2013-10-17 11:05:35 EDT
need to have it in current drop asap, please.
Comment 4 Petr Chalupa 2013-10-18 05:30:06 EDT
We've looked at this with Garik today and we couldn't reproduce. Moving to ON_QA for verification.
Comment 5 Corey Welton 2013-10-18 10:05:02 EDT
Cannot repro either with 1.4.6-39.el6sat

[root@qe-blade-09 ~]# katello --user admin --password admin org delete --name fibble
Successfully deleted org [ fibble ]   

QA Closing, can reopen if it appears again.

Note You need to log in before you can comment on or make changes to this bug.