Bug 1015721 - Migration fails due to bad call to vdsm api
Migration fails due to bad call to vdsm api
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-ha (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Greg Padgett
Artyom
sla
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 19:25 EDT by Greg Padgett
Modified: 2016-06-12 19:16 EDT (History)
8 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-ha-0.1.0-0.3.1.beta1.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:50:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
agent and vdsm logs (21.42 KB, application/zip)
2013-10-28 15:21 EDT, Artyom
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19872 None None None Never
oVirt gerrit 19873 None None None Never

  None (edit)
Description Greg Padgett 2013-10-04 19:25:35 EDT
Description of problem:
Hosted engine agent fails to migrate the engine vm to another host due to a bad call to the 'migrate' vdsm verb.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set up 2 hosted engine hosts
2. Let agent start vm
3. Make other host have much higher score to trigger migration (one way is to block the first host's gateway access using iptables)

Actual results:
Migration fails, noted in /var/log/ovirt-hosted-engine-ha/agent.log.  The vm is shut down and then restarted on the other host.

Expected results:
Migration succeeds and vm should move to other host without the restart.

Additional info:
Comment 1 Greg Padgett 2013-10-14 18:07:41 EDT
Merged:
Change-Id: I9931d6c87b0798152bf344ddd8b9328ce01565a8
Change-Id: I25aaaa3d6cc32a8e36e6366a24cf2db43c0039b0
Comment 3 Artyom 2013-10-28 15:21:00 EDT
Created attachment 816879 [details]
agent and vdsm logs

Verification failed on ovirt-hosted-engine-ha-0.1.0-0.3.1.beta1.el6ev.noarch
Migration failed.
See logs for more details
Comment 4 Artyom 2013-11-11 09:19:39 EST
Migration works from host with low cpu to high cpu and fail from high cpu to low.
Cluster set with low_cpu.
Comment 5 Greg Padgett 2013-11-11 12:09:01 EST
Artyom, can you open up a new bz for this one?  It looks like the original issue of the bad api call is resolved (as some migrations work), and another issue related to cluster cpu levels has come up.  Thanks.
Comment 6 Artyom 2013-11-11 13:23:56 EST
When I migrate from low to high all work fine and no error in vdsm or agent log
Done https://bugzilla.redhat.com/show_bug.cgi?id=1029138
Comment 7 Greg Padgett 2013-11-11 13:50:41 EST
Thanks for opening the new bug.  Moving this one back to on_qa, while looking into the other.
Comment 8 Artyom 2013-11-14 08:09:24 EST
Verified on ovirt-hosted-engine-ha-0.1.0-0.5.1.beta1.el6ev.noarch
Comment 9 Charlie 2013-11-27 20:41:47 EST
This bug is currently attached to errata RHEA-2013:15591. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 Greg Padgett 2013-12-06 13:00:55 EST
ovirt-hosted-engine-ha is a new package; does not need errata for bugs during its development.
Comment 11 errata-xmlrpc 2014-01-21 11:50:33 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0080.html

Note You need to log in before you can comment on or make changes to this bug.