Bug 1015742 - Cannot create new keyring or open existing keyring files
Cannot create new keyring or open existing keyring files
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-05 00:13 EDT by James
Modified: 2013-10-07 05:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 05:36:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James 2013-10-05 00:13:11 EDT
Description of problem: Historically I've been able to copy .gnome2/keyrings/* to my home directory and after running Seahorse the stored passwords would be available. After upgrading to F19+Mate, this no longer works. Seahorse simply shows an empty login keyring and an empty keyring with a blank name. I tried deleting both of these and creating a new keyring but I can't add any keys to it since it never shows up in the 'Add Password' dialog box. I only use the keyring for stored passwords(unless something else uses it silently).


Version-Release number of selected component (if applicable):
gnome-keyring.x86_64                     3.8.2-1.fc19                     @koji-override-0/$releasever
gnome-keyring-sharp.x86_64               1.0.1-0.12.133722svn.fc19        @fedora                     
gnome-python2-gnomekeyring.x86_64        2.32.0-14.fc19                   @fedora                     
libgnome-keyring.x86_64                  3.8.0-1.fc19                     @koji-override-0/$releasever
libmatekeyring.x86_64                    1.6.0-1.fc19                     @koji-override-0/$releasever
mate-keyring.i686                        1.6.0-2.fc19                     @fedora                     
mate-keyring.x86_64                      1.6.0-2.fc19                     @koji-override-0/$releasever
mate-keyring-pam.x86_64                  1.6.0-2.fc19                     @koji-override-0/$releasever
seahorse.x86_64                          3.8.2-1.fc19                     @fedora

Both gnome-keyring-daemon and mate-keyring-daemon are running. mate-screensaver has a dependency on mate-keyring so I can't remove it. I also see these every so often in the logfiles:

Sep 30 08:28:07 localhost gnome-keyring-daemon[1495]: couldn't register in session: The name org.gnome.SessionManager was not provided by any .service files
Sep 30 08:28:07 localhost gnome-keyring-daemon[1495]: another secret service is running
Comment 1 James 2013-10-05 00:21:06 EDT
So killing the mate-keyring-daemon process, deleting the keyring and making a new keyring seems to work. Overwriting the file in  .local/share/keyrings with my old file, restarting Seahorse and entering my old login password unlocked the keyring. It seems to understand it is a login keyring, but it isn't using my current login password.
Comment 2 Stef Walter 2013-10-07 05:36:47 EDT
~/.local/share/keyrings is the new location for keyrings, in compliance with the XDG Basedir spec. However, if ~/.gnome2/keyrings exists then it is used instead as a compatibility measure.

I hope that clears things up.

Note You need to log in before you can comment on or make changes to this bug.