Bug 1015912 - When creating new host group in foreman WebUI i get (Error while loading activation keys from Katello)
When creating new host group in foreman WebUI i get (Error while loading acti...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Walden Raines
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-06 14:07 EDT by pgustafs
Modified: 2013-10-11 11:47 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-11 11:47:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log files (147.60 KB, application/gzip)
2013-10-10 10:54 EDT, pgustafs
no flags Details

  None (edit)
Description pgustafs 2013-10-06 14:07:14 EDT
Description of problem:
When creating a new hostgroup in foreman webUi i get (Error while loading activation keys from Katello) when i'm selecting an environment.

Below is from production.log


Started POST "/foreman/hostgroups/environment_selected" for 127.0.0.1 at 2013-10-06 20:02:51 +0200
Processing by HostgroupsController#environment_selected as */*
  Parameters: {"utf8"=>"✓", "authenticity_token"=>"3UW7j8lxZBH/GD/ro4BOdh8xm/JhZg1mAmBp7wR66iU=", "hostgroup"=>{"parent_id"=>"", "name"=>"RHEL-64", "environment_id"=>"3", "puppet_ca_proxy_id"=>"", "puppet_proxy_id"=>"", "domain_id"=>"", "architecture_id"=>"", "root_pass"=>"[FILTERED]", "organization_ids"=>["", ""]}, "kt_activation_keys"=>"", "host_id"=>"null"}
  Rendered puppetclasses/_selectedClasses.html.erb (0.0ms)
  Rendered puppetclasses/_classes.html.erb (0.1ms)
  Rendered puppetclasses/_class_selection.html.erb (3.1ms)
Completed 200 OK in 28ms (Views: 3.8ms | ActiveRecord: 3.6ms)


Started GET "/foreman/foreman_katello_engine/activation_keys?environment_id=3" for 127.0.0.1 at 2013-10-06 20:02:51 +0200
Processing by ForemanKatelloEngine::ActivationKeysController#index as */*
  Parameters: {"environment_id"=>"3"}
Operation FAILED: 401 Unauthorized: Invalid credentials
  Rendered common/500.html.erb (2.8ms)
Completed 500 Internal Server Error in 41ms (Views: 3.4ms | ActiveRecord: 2.1ms)


Version-Release number of selected component (if applicable):
foreman-1.3.0-13.el6sat.noarch
ruby193-rubygem-foreman-katello-engine-0.0.12-10.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.5-5.el6sat.noarch
ruby193-rubygem-foreman_api-0.1.6-1.el6sat.noarch
sat6.pgustafs-foreman-proxy-1.0-1.noarch
sat6.pgustafs-foreman-client-1.0-1.noarch
foreman-proxy-1.3.0-2.el6sat.noarch
foreman-postgresql-1.3.0-13.el6sat.noarch
foreman-compute-1.3.0-13.el6sat.noarch
foreman-libvirt-1.3.0-13.el6sat.noarch
rubygem-foreman_api-0.1.6-1.el6sat.noarch
katello-foreman-all-1.4.6-20.el6sat.noarch
katello-configure-foreman-proxy-1.4.5-9.el6sat.noarch
katello-configure-foreman-1.4.5-9.el6sat.noarch


How reproducible:
Always


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2013-10-06 14:14:31 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Ivan Necas 2013-10-10 10:11:35 EDT
This might be an issue connected to changed way of authenication in recent Foreman. I will look at it.
Comment 4 pgustafs 2013-10-10 10:54:19 EDT
Created attachment 810583 [details]
log files
Comment 5 Ivan Necas 2013-10-11 11:47:13 EDT
The reason for the errors was found: change oauth secret in the foreman UI by the user.

Note You need to log in before you can comment on or make changes to this bug.