This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1015919 - Partition types are not translated
Partition types are not translated
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-06 15:00 EDT by Domingo Becker
Modified: 2014-05-08 12:38 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-08 12:38:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
custom partition layout action table (718.79 KB, image/png)
2013-10-06 15:00 EDT, Domingo Becker
no flags Details
this message is almost invisible (293.84 KB, image/png)
2013-10-06 15:03 EDT, Domingo Becker
no flags Details
a banner at the bottom that seems to be untranslatable (1023.31 KB, image/png)
2013-10-06 15:06 EDT, Domingo Becker
no flags Details

  None (edit)
Description Domingo Becker 2013-10-06 15:00:31 EDT
Created attachment 808617 [details]
custom partition layout action table

There are some strings that seems to be untranslatable in anaconda for Fedora 20.

1. After creating a custom partition layout, a summary of changes appears in a table. The strings in column 'action' appears in English: "Create Device" and "Creat Format".

   In the same table, the column 'Type' shows: ext4, partition, swap, etc. Perhaps those terms should be translated too, for a better end-user experience. In Spanish they would be ext4, partición, intercambio, respectively.

2. When providing a password for the created user, it shows a message in the status bar at the bottom, and that message is untranslatable. Also, the message is almost invisible, there's nothing that indicate the message is there after providing the password. I mean, it's hard to see it.

3. There are a few messages that seem to be bitmaps that are untranslated. One is referrign to share the installation media (CD or DVD), another referring ask.fedoraproject.org and the last one referring fedoraproject.org/join-fedora.

I attached a few bitmaps showing the bugs.
Comment 1 Domingo Becker 2013-10-06 15:03:09 EDT
Created attachment 808618 [details]
this message is almost invisible
Comment 2 Domingo Becker 2013-10-06 15:06:01 EDT
Created attachment 808619 [details]
a banner at the bottom that seems to be untranslatable
Comment 3 David Shea 2013-10-06 23:34:18 EDT
For 2, the message was recently changed. It looks like there's currently a Spanish translation available, so that'll be in the next version of anaconda. As for it being hard to read, something changed in gtk that changed the colors of that message bar on us, so that's something we need to fix. It used to have an orange background and that seemed to work pretty ok.

For 3, anaconda actually supports loading images for different languages, but no one has made any yet. See bug 1013280.

1 is probably in python-blivet.
Comment 4 David Shea 2013-10-07 16:35:26 EDT
"Create Device" and "Create Format" are marked as translatable, but not translation is currently available. The partition types are not marked as translatable.
Comment 5 Domingo Becker 2013-10-07 19:07:31 EDT
(In reply to David Shea from comment #4)
> "Create Device" and "Create Format" are marked as translatable, but not
> translation is currently available. 

Those strings are not in anaconda:

https://fedora.transifex.com/projects/p/anaconda/resource/master/

The pot file in transifex may be outdated.

> The partition types are not marked as
> translatable.

I meant for a better user experience. If it's not possible, no problem.

Thank you!
Comment 6 David Shea 2013-10-08 10:00:24 EDT
(In reply to Domingo Becker from comment #5)
> (In reply to David Shea from comment #4)
> > "Create Device" and "Create Format" are marked as translatable, but not
> > translation is currently available. 
> 
> Those strings are not in anaconda:
> 
> https://fedora.transifex.com/projects/p/anaconda/resource/master/

They're in blivet.

https://www.transifex.com/projects/p/blivet/

> > The partition types are not marked as
> > translatable.
> 
> I meant for a better user experience. If it's not possible, no problem.

Right, I was just making a note of what the issue is and why the strings aren't translated.
Comment 7 Domingo Becker 2013-10-08 18:12:48 EDT
Are there any other module like blivet in use by anaconda, that has a separate project in transifex?

We should let trans list know about this module, so other teams may translate it too.
Comment 8 Domingo Becker 2013-10-08 22:28:33 EDT
(In reply to David Shea from comment #6)
> 
> They're in blivet.
> 
> https://www.transifex.com/projects/p/blivet/
> 

They are translated to Spanish now. 

Will there be a chance to test it by Beta release?

Note You need to log in before you can comment on or make changes to this bug.