Bug 1015920 - nouveau module crash during boot
nouveau module crash during boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-06 15:46 EDT by Fred New
Modified: 2013-10-18 15:31 EDT (History)
9 users (show)

See Also:
Fixed In Version: kernel-3.11.4-101.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-13 15:55:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The messages on my screen also appear in dmesg. (116.33 KB, text/x-log)
2013-10-06 15:46 EDT, Fred New
no flags Details
Xorg.0.log (18.29 KB, text/x-log)
2013-10-06 15:47 EDT, Fred New
no flags Details

  None (edit)
Description Fred New 2013-10-06 15:46:03 EDT
Created attachment 808622 [details]
The messages on my screen also appear in dmesg.

Description of problem:
Something goes wrong with the nouveau driver during boot of F20. My console fills with oops messages and my keyboard appears to be locked. I am able to log into the system using SSH, however.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nouveau-1.0.9-2.fc20.x86_64
kernel-3.11.3-301.fc20.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install F20 using VNC since Anaconda was unable to determine how to get graphical mode working.
2. Boot the new system (into multi-user.target).
2. Remove nomodeset from the boot parameters.
3. Set systemd's default.target to graphical.target.
4. Reboot

Actual results:
A screen full of oops messages and a locked keyboard.

Expected results:
Well, since I couldn't get a graphical session in F19 and since Anaconda didn't know how to handle my display, I can't say that I was expecting much. But I was hoping to get a graphical session working.


Additional info:
[fred@envy17 ~]$ lspci | egrep 'VGA|NVIDIA'
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)

[fred@envy17 ~]$ lsmod | egrep 'i915|nouveau'
nouveau               943445  0 
i915                  651904  3 
mxm_wmi                12865  1 nouveau
ttm                    79865  1 nouveau
i2c_algo_bit           13257  2 i915,nouveau
drm_kms_helper         50239  2 i915,nouveau
drm                   278576  4 ttm,i915,drm_kms_helper,nouveau
i2c_core               34242  7 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit,nouveau,videodev
wmi                    18697  3 hp_wmi,mxm_wmi,nouveau
video                  19104  2 i915,nouveau
[fred@envy17 ~]$
Comment 1 Fred New 2013-10-06 15:47:08 EDT
Created attachment 808623 [details]
Xorg.0.log
Comment 2 Fred New 2013-10-07 03:01:28 EDT
For future reference, the "Fedora 20" I installed was actually Fedora 20 Beta Test Compose 1 (TC1) (network installation), since this is the latest "Fedora 20" currently available. I expect to be re-installing newer variants of F20 as its development progresses.
Comment 3 Ben Skeggs 2013-10-08 02:45:49 EDT
Issue already fixed upstream, and in kernel 3.12.  I've sent the fix for the stable 3.11 tree too, and the Fedora kernel devs will pick it up from there.

Reassigning to those guys until they do!
Comment 4 Josh Boyer 2013-10-08 08:25:16 EDT
commit 5495e39fb3695182b9f2a72fe4169056cada37a1 upstream, correct?
Comment 5 Ben Skeggs 2013-10-08 10:25:58 EDT
That's the one.
Comment 6 Josh Boyer 2013-10-08 11:57:59 EDT
Added in Fedora git.  The upstream stable maintainer is traveling at the moment, so who knows when he'll do another stable release.
Comment 7 Fedora Update System 2013-10-10 13:41:08 EDT
kernel-3.11.4-201.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.11.4-201.fc19
Comment 8 Fedora Update System 2013-10-10 13:41:31 EDT
kernel-3.11.4-101.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.11.4-101.fc18
Comment 9 Fedora Update System 2013-10-10 18:33:52 EDT
kernel-3.11.4-301.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.11.4-301.fc20
Comment 10 Fedora Update System 2013-10-10 22:32:49 EDT
Package kernel-3.11.4-201.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.11.4-201.fc19'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18820/kernel-3.11.4-201.fc19
then log in and leave karma (feedback).
Comment 11 Fred New 2013-10-11 18:03:55 EDT
Yep, kernel-3.11.4-301.fc20.x86_64 boots successfully without the nouveau module crashing.
Comment 12 Fedora Update System 2013-10-13 15:55:53 EDT
kernel-3.11.4-301.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-10-14 03:11:03 EDT
kernel-3.11.4-201.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-10-14 13:17:57 EDT
kernel-3.11.4-201.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-10-18 15:31:43 EDT
kernel-3.11.4-101.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.