Bug 1015975 - RHEVM-CLI: incorrect property to python built-in symbol encapsulation
RHEVM-CLI: incorrect property to python built-in symbol encapsulation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-cli (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity unspecified
: ---
: 3.3.0
Assigned To: Ravi Nori
Shai Revivo
infra
: Regression
: 1015447 1016632 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 03:45 EDT by Michael Pasternak
Modified: 2016-02-10 14:46 EST (History)
8 users (show)

See Also:
Fixed In Version: is18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:18:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19940 None None None Never

  None (edit)
Description Michael Pasternak 2013-10-07 03:45:57 EDT
Description of problem:

bug
===

[oVirt shell (connected)]# add role --name MyRole --permits-permit "permit.id=1300"

error: "id_" is invalid segment at option "--permit.id=1300".

cause:
=====

fixing bug 1005751, - 'id' should not be suffixed with '_' despite it python
built-in symbol.


resolution: 
==========

before appending '_' suffix to properties that match python built-in symbols,
check if such property exist in object.
Comment 2 Michael Pasternak 2013-10-08 09:10:47 EDT
*** Bug 1016632 has been marked as a duplicate of this bug. ***
Comment 3 Michael Pasternak 2013-10-14 07:34:57 EDT
*** Bug 1015447 has been marked as a duplicate of this bug. ***
Comment 4 Ilia Meerovich 2013-10-16 04:53:08 EDT
Verified with IS18
Comment 7 Itamar Heim 2014-01-21 17:18:06 EST
Closing - RHEV 3.3 Released
Comment 8 Itamar Heim 2014-01-21 17:24:30 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.