Bug 1015977 - [abrt] hpijs-3.13.9-2.fc19: hpps:52:bug:NameError: global name 'log' is not defined
[abrt] hpijs-3.13.9-2.fc19: hpps:52:bug:NameError: global name 'log' is not d...
Status: CLOSED DUPLICATE of bug 984699
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:1747c49fccdebf2b45491650736...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 03:59 EDT by kluksa
Modified: 2014-07-17 13:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 04:55:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (439 bytes, text/plain)
2013-10-07 03:59 EDT, kluksa
no flags Details
File: environ (920 bytes, text/plain)
2013-10-07 03:59 EDT, kluksa
no flags Details

  None (edit)
Description kluksa 2013-10-07 03:59:09 EDT
Description of problem:
Tried to print to HP Color LJ 5550 via ipp.

Version-Release number of selected component:
hpijs-3.13.9-2.fc19

Additional info:
reporter:       libreport-2.1.7
cmdline:        python /usr/lib/cups/filter/hpps 136 kraljevic Andro_pozivnica.pdf 6 'HPPhotoHalftone=Detail HPGraphicsNeutralGrays=Black HPGraphicsRGB=sRGB HPTextRGB=sRGB Duplex=None number-up=1 Collate HPEdgeControl=Normal HPPhotoRGB=sRGB noManualFeed HPGraphicsHalftone=Detail ColorModel=Gray noHPStraightPaperPath InputSlot=Auto HPTextHalftone=Detail HPPhotoNeutralGrays=ProcessBlack HPTextNeutralGrays=Black HPCMYKInks=Default PageSize=A4 MediaType=Plain job-uuid=urn:uuid:98540805-64d7-3d98-411c-f7ed70a06180 job-originating-host-name=localhost time-at-creation=1380700040 time-at-processing=1380700040'
executable:     /usr/lib/cups/filter/hpps
kernel:         3.11.1-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            4

Truncated backtrace:
hpps:52:bug:NameError: global name 'log' is not defined

Traceback (most recent call last):
  File "/usr/lib/cups/filter/hpps", line 86, in <module>
    bug("Error importing HPLIP modules:%s %s\n" % (pid, e))
  File "/usr/lib/cups/filter/hpps", line 52, in bug
    log.stderr("ERROR: %s" % m)
NameError: global name 'log' is not defined

Local variables in innermost frame:
m: 'Error importing HPLIP modules:2972 No module named base.g\n'
Comment 1 kluksa 2013-10-07 03:59:14 EDT
Created attachment 808743 [details]
File: backtrace
Comment 2 kluksa 2013-10-07 03:59:17 EDT
Created attachment 808744 [details]
File: environ
Comment 3 Jiri Popelka 2013-10-07 04:55:25 EDT
Looks like the hpps filter needs the same patch as hpfax backend in bug #984699.
I'll check whether there are more places like this and update upstream bug (Launchpad 1201767)

*** This bug has been marked as a duplicate of bug 984699 ***
Comment 4 Sergey Zubov 2014-01-13 02:07:52 EST
Try to install hplip package. Works for me.
Comment 5 lejeczek 2014-01-15 05:42:20 EST
I get this hplip crash with my
HP-LaserJet-500-color-M551 when I try to print test page from gnome printers applet
but not with
Hewlett-Packard-HP-LaserJet-P3010-Series
and there are both installed on same one fedora 20
Comment 6 lejeczek 2014-01-15 06:30:00 EST
sorry, yes, my p3010 runs on hpcups 3.13.11
and yes, hplip solves the problem, besides if we follow instructions @

http://hplipopensource.com/hplip-web/install_wizard/index.html

for HP-LaserJet-500-color-M551 printer then hplip in obviously necessary

Note You need to log in before you can comment on or make changes to this bug.