Bug 1016023 - Just first volume may be successfully created by cinder (both Grizzly and Havana) on F19
Just first volume may be successfully created by cinder (both Grizzly and Ha...
Status: CLOSED NOTABUG
Product: RDO
Classification: Community
Component: openstack-cinder (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity unspecified
: ---
: Havana
Assigned To: RHOS Maint
Giulio Fidente
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 06:32 EDT by Boris Derzhavets
Modified: 2016-04-26 16:09 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 08:12:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Derzhavets 2013-10-07 06:32:00 EDT
Description of problem:

[root@localhost ~(keystone_admin)]# nova image-list
+--------------------------------------+-----------------------------+--------+--------+
| ID                                   | Name                        | Status | Server |
+--------------------------------------+-----------------------------+--------+--------+
| 0183d5fb-96f8-4e94-a8b7-aaaccedac3e9 | Fedora19image               | ACTIVE |        |
| 7fc2b813-213d-4a87-9e84-54e815738ce0 | Ubuntu13.10-0929            | ACTIVE |        |
| 6df87f2d-7dd9-4531-9337-d564980896ef | Ubuntu1310image             | ACTIVE |        |
| 32ae031d-3bc0-4a38-a355-f9a8fa8be6e6 | Windos Server 2012 Std Eval | ACTIVE |        |
| 9afaab34-2bce-46a0-8589-460cb03ce246 | cirros                      | ACTIVE |        |
+--------------------------------------+-----------------------------+--------+--------+
[root@localhost ~(keystone_admin)]# cinder create --image-id  6df87f2d-7dd9-4531-9337-d564980896ef --display_name ub13volume  16
+---------------------+--------------------------------------+
|       Property      |                Value                 |
+---------------------+--------------------------------------+
|     attachments     |                  []                  |
|  availability_zone  |                 nova                 |
|       bootable      |                false                 |
|      created_at     |      2013-10-07T10:14:12.319562      |
| display_description |                 None                 |
|     display_name    |              ub13volume              |
|          id         | 9cef454b-d266-4c8d-9642-b52c5e1d694b |
|       image_id      | 6df87f2d-7dd9-4531-9337-d564980896ef |
|       metadata      |                  {}                  |
|         size        |                  16                  |
|     snapshot_id     |                 None                 |
|     source_volid    |                 None                 |
|        status       |               creating               |
|     volume_type     |                 None                 |
+---------------------+--------------------------------------+
[root@localhost ~(keystone_admin)]# nova volume-list
+--------------------------------------+--------+--------------+------+-------------+--------------------------------------+
| ID                                   | Status | Display Name | Size | Volume Type | Attached to                          |
+--------------------------------------+--------+--------------+------+-------------+--------------------------------------+
| 9cef454b-d266-4c8d-9642-b52c5e1d694b | error  | ub13volume   | 16   | None        |                                      |
| b9510db2-88ba-467f-b2ac-8adecbae47e6 | in-use | testvolume1  | 16   | None        | 1d2865e0-cd81-437f-9900-ecede2e1bba0 |
+--------------------------------------+--------+--------------+------+-------------+--------------------------------------+
[root@localhost ~(keystone_admin)]# pvscan
  PV /dev/sdb7    VG fedora00         lvm2 [173.91 GiB / 0    free]
  PV /dev/sda5    VG fedora_800       lvm2 [125.08 GiB / 0    free]
  PV /dev/sdb2    VG fedora           lvm2 [125.08 GiB / 0    free]
  PV /dev/sda2    VG fedora_8         lvm2 [85.94 GiB / 7.81 GiB free]
  PV /dev/loop1   VG cinder-volumes   lvm2 [20.00 GiB / 4.00 GiB free]
  PV /dev/sdb5    VG fedora_801       lvm2 [154.38 GiB / 0    free]
  Total: 6 [684.37 GiB] / in use: 6 [684.37 GiB] / in no VG: 0 [0   ]

Version-Release number of selected component (if applicable):

openstack-cinder-2013.1.3-1.fc19.noarch

How reproducible:

Attempt to create just second cinder volume generates error status.

Steps to Reproduce:
1. Install openstack Grizzly ( or Havana) allinone on Fedora 19
2. Make sure VG cinder-volumes exists
3. Try to create several cinder volumes via images of Fedora 19 or Ubuntu 13.10

Actual results:

Second attempt failes.

Expected results:

Second volume to get status "available"

Additional info:
Comment 1 Pádraig Brady 2013-10-07 08:12:45 EDT
I'm guessing that this is a size issue.
cinder-volumes is 20G and you're trying to create 2 * 16G?
Please reopen if this isn't the case.

Since you're mentioning Havana also, I'm moving this to RDO.

thanks.
Comment 2 Boris Derzhavets 2013-10-09 13:25:39 EDT
Thanks. I've already got it as well.

Note You need to log in before you can comment on or make changes to this bug.