Bug 1016079 - FSW 6.0.0 ER4 multiple SwitchYard quickstarts fail during jboss-as:deploy phase as they run tests - trying to start already started server
FSW 6.0.0 ER4 multiple SwitchYard quickstarts fail during jboss-as:deploy pha...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity medium
: ER7
: 6.0.0
Assigned To: Douglas Palmer
ppecka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 09:00 EDT by ppecka
Modified: 2014-06-16 19:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:26:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1773 Major Closed Some quickstarts fail tests when running mvn jboss-as:deploy 2014-06-16 19:51:27 EDT

  None (edit)
Description ppecka 2013-10-07 09:00:29 EDT
Description of problem:
Multiple quickstarts are running tests during jboss-as:deploy phase, consequently due to application server is already running - maven goal fails. for example camel-jaxb

Version :
soa-6.0.0-ER4


Expected results:
Users are able to run quickstarts as described in Readme, no workarounds needed
Comment 1 Keith Babo 2013-10-14 15:07:30 EDT
Doug - we need to use system properties to override the default port used by the standalone netty http server for all tests which use the HTTP or REST bindings.  Do you mind looking through the quickstarts for all instances of binding.http and binding.rest and collecting the changes under this BZ?  Ping me on IRC or email and I can give you details on how to configure the port setting for test.

thanks,
keith
Comment 2 Douglas Palmer 2013-10-15 05:06:22 EDT
We need to fix this for the following quickstarts:

camel-jaxb
http-binding
rest-binding
Comment 3 Douglas Palmer 2013-10-16 06:20:50 EDT
Quickstarts with binding.soap also fail; these are:

camel-soap-proxy
soap-addressing
soap-attachment
soap-binding-rpc
Comment 4 JBoss JIRA Server 2013-11-12 14:25:25 EST
Keith Babo <kbabo@redhat.com> made a comment on jira SWITCHYARD-1773

pushed
Comment 5 ppecka 2013-12-20 09:43:40 EST
VERIFIED
Comment 6 JBoss JIRA Server 2014-06-16 19:51:27 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1773 to Closed

Note You need to log in before you can comment on or make changes to this bug.