Bug 1016122 - /usr/bin/smbpasswd in "samba-client"
/usr/bin/smbpasswd in "samba-client"
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Guenther Deschner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 10:43 EDT by Harald Reindl
Modified: 2015-01-05 10:44 EST (History)
10 users (show)

See Also:
Fixed In Version: samba-4.2.0-0.1.rc3.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-05 10:44:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-10-07 10:43:22 EDT
[root@rh:~]$ rpm -q --file /usr/bin/smbpasswd
samba-client-4.0.9-2.fc19.x86_64

that is IMHO a mistake because i refuse to understand why i need to install the client package on a server to add a samba-user or change it's password

affects F18/F19
Comment 1 Dmitri Pal 2013-10-07 11:54:31 EDT
Harald,

It is unclear what are you suggesting here.
How would you want this to happen differently?

Thanks
Dmitri
Comment 2 Harald Reindl 2013-10-07 12:14:30 EDT
move it to "samba" or "samba-common"?

i had yesterday to install "libsmbclient" and "samba-client"
to change one users password on a *server*

Oct 05 18:34:23 Installed: 2:libsmbclient-4.0.9-1.fc18.x86_64
Oct 05 18:34:23 Installed: 2:samba-client-4.0.9-1.fc18.x86_64
Comment 3 Harald Reindl 2013-12-30 13:00:18 EST
ping

it makes really no sense that you need to install "samba-client" to get the "smbpasswd" command on a *server* where you need it to add a samba-user or change his password
Comment 4 Guenther Deschner 2014-01-10 09:29:05 EST
Hello Harald,

until we came to conclusion how to deal with this, can you use the "pdbedit -a" tool to add and change passwords of users ? pdbedit is already in samba-common.

Thanks,
Guenther
Comment 5 Harald Reindl 2014-01-10 09:50:30 EST
for now i simply added "samba-client" to my meta-packages containing "samba", but as i not that often need to add/change users and obviously cleaned up the machines proper i really wondered where the command went
Comment 6 stadtkind2 2014-09-28 06:20:09 EDT
Hi,

I had the same problem today (F20). Samba server, users added with pdbedit and now I have to change a password. No idea how to do this with pdbedit and smbpasswd is not available even though there's a manpage installed:

$ rpm -ql samba-common-4.1.9-4.fc20.x86_64 | grep pass
/usr/lib64/samba/pdb/smbpasswd.so
/usr/share/man/man5/smbpasswd.5.gz

So now what? Do I have to delete my smb user with pdbedit and re-add it again just to change the password? This makes no sense.

Please add smbpasswd to samba-common (or remove the smbpasswd manpage there). Thanks.
Comment 7 Harald Reindl 2014-09-28 06:23:01 EDT
that is a *major* packaging bug and i don't get that nobody fixes this - there is no valid reason that you need "samba-client" to change a password on a server
Comment 8 Michael Adam 2014-12-11 09:40:01 EST
(In reply to stadtkind2 from comment #6)
> Hi,
> 
> I had the same problem today (F20). Samba server, users added with pdbedit
> and now I have to change a password. No idea how to do this with pdbedit and
> smbpasswd is not available even though there's a manpage installed:
> 
> $ rpm -ql samba-common-4.1.9-4.fc20.x86_64 | grep pass
> /usr/lib64/samba/pdb/smbpasswd.so
> /usr/share/man/man5/smbpasswd.5.gz
> 
> So now what? Do I have to delete my smb user with pdbedit and re-add it
> again just to change the password? This makes no sense.

This is not a bug:

- The smbpasswd.so is the shared object that implements the
  smbpasswd backend to the passdb pluggable subsystem in Samba.
  This is used by both server and client commands.
- The smbpasswd.5 manpage is the manpage for the smbpasswd file.
  This belongs to the implementation of the backend, i.e. the
  smbpasswd.so
- The smbpasswd binary and its accompanying manpage (smbpasswd.8)
  are currently in the samba-client package, which is under discussion
  here. But at least it is consistent!

We are currently discussing whether to move smbpasswd (tool+man)
to the client package. Both make some amount of sense to us.

Michael
Comment 9 Harald Reindl 2014-12-11 09:52:34 EST
"This is used by both server and client commands" - well, that's why it belongs to the "common" package you have installed on servers as well as clients while you typically don't need the client package on a server
Comment 10 Michael Adam 2014-12-11 10:09:17 EST
(In reply to Harald Reindl from comment #9)
> "This is used by both server and client commands" - well, that's why it
> belongs to the "common" package you have installed on servers as well as
> clients while you typically don't need the client package on a server

Yes, the "it" I was referring to is in this case the
smbpasswd.so and smbpasswd.5, which *are* in the common package. :-)

Michael
Comment 11 Harald Reindl 2014-12-11 10:12:23 EST
so why can than be the small "/usr/bin/smbpasswd" also be there instead enforce installation of "smaba-client" just to add a new user or change a password on the server?

-rwxr-xr-x 1 root root 32K 2014-10-07 20:00 /usr/bin/smbpasswd
Comment 12 Michael Adam 2014-12-11 10:17:03 EST
Yes, it could be there. I understand your reasoning.
As I wrote above: we are currently discussing the pro-s and con-s
and will update the bug report shortly.

Stay tuned - Michael
Comment 13 Andreas Schneider 2015-01-05 10:44:03 EST
I've move the smbpasswd utility to samba-common package in rawhide.

Note You need to log in before you can comment on or make changes to this bug.