Bug 1016166 - Logs translated by locale
Logs translated by locale
Status: CLOSED NOTABUG
Product: Candlepin
Classification: Community
Component: candlepin (Show other bugs)
0.9
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: candlepin-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 12:04 EDT by Dennis Crissman
Modified: 2015-05-14 10:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-07 14:52:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Crissman 2013-10-07 12:04:48 EDT
Logs come out in different languages, presumably based on locale. This is great for the user, not so great for debugging.

Example:

Oct 07 09:43:01 [http-8080-8] WARN  org.candlepin.resource.ConsumerResource - Unable to attach a subscription for a product that has no pool: No entitlements for products: [69]
 
Oct 07 09:43:56 [http-8080-8] WARN  org.candlepin.resource.ConsumerResource - Impossible dattacher un abonnement pour un produit qui ne possède pas de pool : {0}
Comment 1 William Poteat 2014-01-07 14:52:32 EST
Messages that are intended for the client are translated for the client . They are also occasionally logged. There is not a useful way to log in english only but return translated messages to the logs.
Comment 2 William Poteat 2014-01-07 14:53:08 EST
return translated messages to the client

Note You need to log in before you can comment on or make changes to this bug.