Bug 1016169 - Monotone upgrade to fedora 20 fails because botan doesn't exist in fedora 20 repo
Monotone upgrade to fedora 20 fails because botan doesn't exist in fedora 20 ...
Status: CLOSED DUPLICATE of bug 985750
Product: Fedora
Classification: Fedora
Component: monotone (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Moschny
Fedora Extras Quality Assurance
:
: 1016765 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 12:09 EDT by io
Modified: 2013-10-08 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 13:38:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description io 2013-10-07 12:09:52 EDT
Description of problem:
While upgrading distro from 19 to 20 Alpha, I realized that some packages in 20 20 Alpha doesn't have botan.
Please see below:

Error: Package: monotone-1.0-11.fc19.x86_64 (@fedora/19)
           Requires: libbotan-1.8.2.so()(64bit)
           Removing: botan-1.8.14-2.fc19.x86_64 (@fedora/19)
               libbotan-1.8.2.so()(64bit)
           Updated By: botan-1.10.5-4.fc20.x86_64 (fedora)
               Not found


Version-Release number of selected component (if applicable):
20

How reproducible:
Have Fedora 19 distro rawhide, never moved to final release.
Trying to upgrade to 20 alpha.


Steps to Reproduce:
1. yum --releasever=20 distro-sync

Actual results:
Failure to upgrade because of dependencies

Expected results:
Successful upgrade

Additional info:

[root@ioFedora ~]# cat /etc/redhat-release 
Fedora release 19 (Schrödinger’s Cat)

[root@ioFedora ~]# uname -a
Linux ioFedora 3.11.3-201.fc19.x86_64 #1 SMP Thu Oct 3 00:47:03 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Thomas Moschny 2013-10-08 13:32:00 EDT
This is a monotone problem, (albeit caused by a version botan upgrade).

Working on it.
Comment 2 Thomas Moschny 2013-10-08 13:34:05 EDT
*** Bug 1016765 has been marked as a duplicate of this bug. ***
Comment 3 Thomas Moschny 2013-10-08 13:38:34 EDT

*** This bug has been marked as a duplicate of bug 985750 ***

Note You need to log in before you can comment on or make changes to this bug.